Get capibilities error while trying to integrate ML Skill on studio

Hello everyone,

while trying to integrate the custom ML Skill built for my project , i get an error while trying to use machine learning classifier, i supplied the ml skill name and API key ( the one for Document understanding ) and when i press get capibilities i get the following error : an error occured while retrieving capabilities from server , please check the logs for more details.

note: i also tried using ml skill public endpoint instead , still getting the same error.

anyone faced something like this and can help ?

Hey @hishamconber,

The issue is looks like with the end point, Kindly check once if your end point is correct or not, and also have a look on the below thread.


Please check if you have made your skill public. Please go to your ML skill > click modify current deployment. You will see a pop up with the following details. Enable “Make ML Skill Public” and hit confirm. This will enable you to use the ML skill in your studio.