FTP Scope: Server HMAC algorithm not found

I’m trying to use the FTP Scope activity (UiPath.FTP.Activities.WithFtpSession) and I’m getting a “FTP Scope: Server HMAC algorithm not found” when trying to connect to the server via user and (secure)password.

Some of my setup variable values are:
FtpsMode: none
SslProtocols: Default
UseSftp: true
AcceptallCertificates: true

I can connect to the SFTP server with this protocol with my credentials without any problem and without any specific, special set up.

Any hints? Thanks in advance…

Hi @pere
Check this Thread

Hope it helps!!

I suppose you can connect using another SFTP client software.
Therefore I would recommend to check what HMAC protocol is used by the SFTP client to establish the connection. It should be one for followings supported by FTP.Activities package:

Hi @pravallikapaluri ,

No; unfortunately, that’s not the error I’m getting and it has nothing to do with it. I’m gonna try @J0ska , and I’m worried that my server doesn’t support any of the ones the FTP Activity supports… :frowning:

Hi @J0ska ,

The client I’m using is WinSCP. With WinSCP /info I get a list of the ciphers and algorithms supported by the program. The ones that look more similar to me to the “HMAC protocol” are the “SSH MAC algorithms”:

SSH MAC algorithms:
hmac-sha2-256 (hmac-sha2-256-etm@openssh.com)
hmac-sha1 (hmac-sha1-etm@openssh.com)
hmac-sha1-96 (hmac-sha1-96-etm@openssh.com)
hmac-md5 (hmac-md5-etm@openssh.com)

So even if I’m not able to see what the server is using, it should be one of the ones supported by the FTP activity, as all these (and some extra ones) are supported by it.

Other info I can retrieve from the server in the “Server and protocol information” window are:

File transfer protocol = SFTP-3
Cryptographic protocol = SSH-2
SSH implementation = OpenSSH_7.4
Encryption algorithm = AES-256 SDCTR (AES-NI accelerated)
Compression = No

Any hints?

The “FTP Scope: Server HMAC algorithm not found” error typically occurs when the FTP server uses a cryptographic algorithm that is not supported by the FTP activity in UiPath. This error can happen if the server is using a specific HMAC (Hash-based Message Authentication Code) algorithm that is not supported by the FTP activity.

To resolve this issue, you can try the following steps:

  1. Update the FTP activity package: Ensure that you are using the latest version of the FTP activity package in UiPath Studio. Check for any available updates and install them if necessary. Sometimes, newer versions of the package may include support for additional HMAC algorithms.

  2. Check FTP server settings: Verify the HMAC algorithm used by the FTP server. Contact the server administrator or review the server documentation to determine which HMAC algorithms are supported. Ensure that the server is using a supported algorithm.

  3. Adjust FTP activity settings: If the FTP server supports multiple HMAC algorithms, you can try adjusting the FTP activity settings to use a specific algorithm. In the FTP Scope activity, look for properties related to HMAC algorithms or security settings. Experiment with different settings or consult the activity documentation to find the appropriate configuration for your server.

  4. Use a different FTP activity: If the above steps do not resolve the issue, you can try using a different FTP activity package that supports the HMAC algorithm used by your server. There are alternative FTP activity packages available in UiPath ecosystem that may offer broader support for different protocols and algorithms.

If none of the above steps resolve the issue, it may be necessary to reach out to UiPath support or the FTP activity package developer for further assistance. They can provide guidance and potentially address any compatibility issues or limitations with the specific FTP server you are connecting to.

Remember to review the FTP activity documentation and consult with your IT team or server administrator to ensure that the connection settings and security protocols are correctly configured for your specific server environment.

I hope this helps!

Hi @Vajrang and thanks for helping,

  1. No newer versions of the activity are available.

  2. None of the solutions you suggested worked. According to @J0ska’s reply, the activity supports whatever HMAC algorithm the server is using.

  3. No HMAC-related settings are available in the activity properties. Sorry to bother, but better not suggesting something that in advance is not possible. Furthermore, I already checked the “Accept All Certificates” option, the “Use SFTP” one, FTPS Mode is set to “None”, as well as SSL Protocols…

  4. I’m reluctant to try any of the other available SFTP related activities as are provided by third-party developers…

Switch on logging in WinSCP and check what HMAC protocol WinSCP negotiates with the server.

. 2022-12-19 13:43:34.153 Initialised AES-256 SDCTR (AES-NI accelerated) [aes256-ctr] inbound encryption
. 2022-12-19 13:43:34.153 Initialised HMAC-SHA-256 inbound MAC algorithm

If nothing works you could try integrate WinSCP with UiPath via Powershell.


You could also try update the SSH.NET package

and FluentFTP package

Also see this
Server HMAC algorithm not found · Issue #837 · sshnet/SSH.NET · GitHub

It seems that SSH.NET library used by FTP.Activities pachage doesn’t propperly support some new HMAC algorithms :frowning:

Hi @J0ska and thanks for the replies,

Regarding updating SSH.NET and FluentFTP packages… Well, when I search for them, I find out that I don’t have them installed, so in my case it would imply installing them, not updating. I don’t understand the underlying mechanism. If they are dependencies for FTP Activities, how is it that I don’t have them installed? Are you sure this is going to make a difference?

Regarding integrating WinSCP:

In fact that is how our application currently works. And we wanted to switch to a more “compact” solution since we are using authentication via password and having to type it in via the robot each time slows down the process and make thinks more prone to error…

This is so frustrating. I tried using another SFTP activity (SFTP.Activities), just to realize that it throws exactly the same “Server HMAC algorithm not found” (probably because it has tha same SSH.net dependency).

Then there’s this NovigoSolutions.SFTP.Activities, which I couldn’t try because it doesn’t work with a password but just a key file, but also displays the same dependency, and there’s a another package I installed but don’t show any related activity available (I don’t understand why): “FluentFTP” (doesn’t show any dependency).

SSH.NET is installed automatically as deppendency of FTP.Activities. You could try to download the later version from nuget.org and FTP.Activities should use it. But based on information in github I am not sure it will solve the problem :frowning:


How did you integrate WinSCP? Via Powershell or via .NET library?


@J0ska , I already tried updating SSH.NET and it didn’t work.

Regarding WinSCP integration: sorry, I was wrong; I mean plain OpenSSH SCP implementation that comes with Windows 11, as we want to avoid installing any external programs as much as possible.

I have read a bit in github and seems the problem is that SSH.NET doesn’t support “etm” (encrypt-then-mac) variations of MAC algorithms.

So until SSH.NET is updated the only solution of your case is adding non-etm MAC algorithm at SFTP server side.



Thank you for your efforts, @J0ska. Unfortunately, I don’t have access to server configuration.

I’ll try other solutions using third party utilities + run process or via powershell / CMD then.

@pere Did you find a solution for this issue, I am also facing same error when I converted the project into Windows version

In windows legacy everything works good, the error happening only in Windows version

Nope @rumabharathy ; in the end I had to run a process starting WinSCP because this implied that the server and the activity were not talking the same language.

By the way, mine was a Windows LEGACY project.