Filling Form Fields in .PDF Forms in Adobe Reader

My team and I have been unable to select any unique selectors in Adobe Reader while attempting to automate a form filling process.

The primary selector selects the entire form when using UI Explorer.

I have automated form filling on websites dozens of times with no issues, so I assume this a PDF/Adobe specific issue.

I have tried disabling the “assistive technology support” option under Accessibility in Preferences with no success.

I have also implemented a method using OCR Text reading and offsetting the click and Type activities, but this is error prone.

Any solution to this problem? Does the UiPath team have any timeline for adding full PDF and Adobe Reader support?


Did you try to implement it using Send Hotkeys?

Rammohan B.

1 Like

Hi @rautry,
Which adobe reader are you using? If it is Adobe Acrobat Reader DC, maybe the solution quoted in the below thread would help? Try to disable “Enable Assistive technology support” as suggested by @vvaidya.

Are you suggesting using a generic selection and then “[k(tab)]” to cycle through the fields?

I got this to work, but it doesn’t feel very precise.

We’d have to index fields based on their tab order which is conducive to error if the form is ever altered.

Do you have a better way to do this?

Yes, like I said in my original post, I already found this information and tried.

It didn’t work.

I am using Adobe Reader XI.

Hi, sorry about this. Have you tried any of the solutions quoted in this thread:

I tried some of these options without any luck.

I got tired of looking around and turned to Python to automate the process instead.

I used the Python library “PyPDFtk”, located here: GitHub - revolunet/pypdftk: Python module to drive the awesome pdftk binary.

This depends on the installation of PDF Labs’ “PDFtk” (PDF Tool Kit), located here: PDFtk - The PDF Toolkit

I wrote a small script that grabs the field names from the document. Then I wrote another small script that fills out each field without issue.

I launched the Python script from the UiPath activity “Run Python Script” as a test.

This worked best for me. Hope it helps someone else.




I have automated PDF forms using itextsharp library in c#. You can go though their documentation it’s quite easy to implement… No UI interaction required.

can u send ur xaml file for refference pls

Hello UiPath team,

I am having the same issue while trying to fill in v10_Ficha Cliente Particulares.pdf (1.7 MB) the PDF form attached. I have tried all setup changes suggested but it is still not working for me. (Adobe Acrobat Reader DC)

Could you help me please?