Failed to install package - 23.10.0-preview is not compatible with net6.0-windows7.0

Getting this error when Installing a newer version of a bot in UiPath assistant


This error does not show up on my other laptop which also has the same .net6 version

Why is this happening?

Hi @freelance_bot

indicates that there is a compatibility issue between the UiPath package version you are trying to install (23.10.0-preview) and the target runtime environment, specifically “.NET 6.0 Windows 7.0.”

follow steps:

1.Check .NET Version: Ensure that both laptops have the same version of .NET installed, and that it matches the requirements of the UiPath package you’re trying to install. You may need to update or modify the .NET runtime on the laptop where you’re encountering the error.

2.NuGet Package Source: Confirm that both laptops are using the same NuGet package source or feed. You can configure this in UiPath Studio in the “Manage Packages” settings.

3.Dependency Check: Check if there are any specific dependencies required by the UiPath package. Ensure that these dependencies are correctly installed on the laptop where you’re encountering the error.

4.UiPath Version: Make sure that both laptops are running the same version of UiPath and that all updates and patches are applied.

@freelance_bot

Are you getting this when trying to run or when try to install itself?

What version are you trying to instll

Cheers

Hi @Anil_G and @Praveen_Mudhiraj , these are the error messages I’m getting. All these nuget packages are dependencies of the UiPath.excel.activities:

System.Exception: "NU1202: Package ClosedXML 0.95.4 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package ClosedXML 0.95.4 does not support any target frameworks.
NU1202: Package DocumentFormat.OpenXml 2.12.1 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package DocumentFormat.OpenXml 2.12.1 does not support any target frameworks.
NU1202: Package Microsoft.VisualStudio.OLE.Interop 16.7.30328.74 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package Microsoft.VisualStudio.OLE.Interop 16.7.30328.74 does not support any target frameworks.
NU1202: Package NPOI 2.5.5 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package NPOI 2.5.5 does not support any target frameworks.
NU1202: Package SharpZipLib 1.3.3 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package SharpZipLib 1.3.3 does not support any target frameworks.
NU1202: Package CsvHelper 16.0.0 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package CsvHelper 16.0.0 does not support any target frameworks.
NU1202: Package Microsoft.AspNet.SignalR.Client 2.4.0 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package Microsoft.AspNet.SignalR.Client 2.4.0 does not support any target frameworks.
NU1202: Package Microsoft.AspNetCore.SignalR.Client 3.1.6 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package Microsoft.AspNetCore.SignalR.Client 3.1.6 does not support any target frameworks.
NU1202: Package Microsoft.CodeAnalysis.CSharp 4.5.0-2.22527.10 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package Microsoft.CodeAnalysis.CSharp 4.5.0-2.22527.10 does not support any target frameworks.
NU1202: Package Microsoft.CodeAnalysis.Common 4.5.0-2.22527.10 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package Microsoft.CodeAnalysis.Common 4.5.0-2.22527.10 does not support any target frameworks.
NU1202: Package Microsoft.CodeAnalysis.VisualBasic 4.5.0-2.22527.10 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package Microsoft.CodeAnalysis.VisualBasic 4.5.0-2.22527.10 does not support any target frameworks.
NU1202: Package Microsoft.Rest.ClientRuntime 2.3.21 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package Microsoft.Rest.ClientRuntime 2.3.21 does not support any target frameworks.
NU1202: Package AutoMapper 9.0.0 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package AutoMapper 9.0.0 does not support any target frameworks.
NU1202: Package Newtonsoft.Json 13.0.1 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package Newtonsoft.Json 13.0.1 does not support any target frameworks.
NU1202: Package System.IO.Abstractions 3.0.10 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package System.IO.Abstractions 3.0.10 does not support any target frameworks.
NU1202: Package System.Runtime.Caching 5.0.0 is not compatible with net6.0-windows7.0 (.NETCoreApp,Version=v6.0). Package System.Runtime.Caching 5.0.0 supports:

  • monoandroid10 (MonoAndroid,Version=v1.0)
  • monotouch10 (MonoTouch,Version=v1.0)
  • net45 (.NETFramework,Version=v4.5)
  • xamarinios10 (Xamarin.iOS,Version=v1.0)
  • xamarinmac20 (Xamarin.Mac,Version=v2.0)
  • xamarintvos10 (Xamarin.TVOS,Version=v1.0)
  • xamarinwatchos10 (Xamarin.WatchOS,Version=v1.0)

Your Orchestrator and Robot should be higher than 2021.10.6.

Also, for the UiPath.System.Activities.23.10.0-preview, you will need at least a robot with 2023.10.+ version.