Execute query with parameters is not working as expected

Hi All,

I am trying to call one procedure from my project but I’m facing below issue

REQ_No
But I’m passing the reqNo in parameters property of execute query activity

parameter
and this is the proc I’m calling

dbjpg

I’m not understanding where I’m going wrong can anyone help me pls…

1 Like

Hi @Karun
remove the @ in variable name @reqNo and keep as reqNo
and try to execute with the same query… @Karun
or still not working, kindly have a look at this thread


Cheers @Karun

1 Like

Thanks @Palaniyappan for your quick reply

I tried removing @ in @reqNo but still no luck

1 Like

From the above thread, he is saying to write entire query with parameters

then what is the use of Parameters property of Execute Query activity and I have total 10 to 11 parameters to pass, how complex the string will be

Is that the only way to pass parameters to proc?

1 Like

Nobody said that Will be a easy query :slight_smile:

1 Like

Yes @pllo2ptk, Its not a easy query but sending parameters through Parameters property will be the best way for this kind of scenarios I mean when we need to send more parameters