Execute Non Query/Access Error

Hello,

To start 2 days ago this worked but now get the below.

I am trying a very simple Access database post ( I had issues with a more complicated one and boiled it down still having the same issues). I am trying to take 3 variables and post them to the Access database. See below screen show. The Access table is setup correctly (correct header names) but I am getting a very generic “Execute Non Query” error stating “No Condition defined” and the exception stating "RemoteException wrapping System.Data.OleDb.OleDbException: Syntax error in INSERT INTO statement. ". The DB connects just fine and and “DatabaseConnection” is set to testdb.

The Insert statement: “Insert Into TestDB ( first, last, middle ) values (”+first+","+last+","+middle+")"

Any thoughts on why I am gettign the error on the execute non query side?

Hi @Hallowell

Have you try to execute your query in the back end ?

cheers :smiley:

Happy learning :smiley:

3 Likes

Hi
Welcome to uipath community
Kindly try with this statement
”Insert Into TestDB ( first, last, middle ) values (@first,@ last,@middle)”

Hope this would help you
Cheers @Hallowell

Hey,

Thanks for the quick response. I change to - “Insert Into TestDB ( first, last, middle ) values (@first,@last,@middle)” - but still have the same issue. The frustrating issue is this worked 2 days ago in a different project.

Thanks

Hello team,
I’m facing the same error while executing the project. Help me to solve this error

strQuery= “INSERT INTO FundTransaction (FundName,RequestType,RequestFrom,RequestStatus,Quantity) VALUES (”+""+fundName+","+""+fundtype+","+""+userAddress+","+“Received”+","+""+fundQuantity+""+" ) ;"

Hey Vrushali,

I assume you are following the edureka RPA tutorial because I am and our code looks similar. I spent over an hour trying to figure out what we both did wrong. Turns out I messed up two small details

  1. There are multiple spots in the code where I wrote “”. Turns out that there is an single quote in the middle of that so you need to change every place where it says “” to “’”.

  2. The word Received needs to be inside single quotes inside of double quotes. So you need to change “Received” to “‘Received’”

I hope this helps solve your problem, it sure caused me a lot of frustration.

1 Like