Exception Type: BrowserOperationException: Cannot communicate with Internet Explorer browser


#1

Hi,

someone please check this ASAP, i have tried reinstalling all packages and running that DLL from cmd prompt and also reset IE Browser advanced setting, tried everything you guys mentioned in all other forums.

Scenario: Open any URL in IE browser

Steps to reproduce: just use Open browser function and try to open any URL

Current Behavior: throwing below exception

Expected Behavior: Should open browser with Error

Studio/Robot/Orchestrator Version: VERSION 2018.1.0

Last stable behavior: was working fine before Version updated to 2018.1.0
Last stable version:
OS Version: Windows 10
Others if Relevant: (workflow, logs, .net version, service pack, etc):

test has thrown an exception

Source: Open browser

Message: Cannot communicate with Internet Explorer browser.

Exception Type: BrowserOperationException

UiPath.Core.BrowserOperationException: Cannot communicate with Internet Explorer browser. —> System.Runtime.InteropServices.COMException: Cannot communicate with Internet Explorer browser.
at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)
at UiPath.Core.Browser.Open(String url, Boolean privateSession, Boolean headlessSession, Boolean defaultSession)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


#2

Please check if u have updated IE browser. IE 11 works well. Simply use start process activity and specify d path of internet explorer. Exe in that activity.
In the argument I.e second line of start process activity , type Google. Com in double quotes and run work flow . Internet explorer wil open Google


#3

Also, with uiexplorer, detection works inside IE? Any webpage…


#4

Able to launch application now but rest of my script isn’t working which was working for last two weeks.

if i record steps again then it is working, but what about remaining steps do i have record them all again???

why all of a sudden Open Browser stopped working for IE? why is it so unstable? what if i have a complete Automation is completed and Starting point of opening browser stopped do i have to change complete Automation?


#5

@leo,

Well, as per what you have mentioned :

Not really sure what caused this instability, but last time, when I ran the same work flow (that i created on my system ) on a different system, the BOT was not able to pick up selectors properly and that was not because of the instability reasons, but because the version of IE on that system was 8 and when I upgraded to IE11 it started running smoothly.

Well, having said this I am not judging, because I don’t know your script well and I am unaware of any new updates in your system that might have caused this issue.

So probably, IF your are starting your workflow with opening a browser, instead of using Open Browser activity , please use Start Process Activity as it would work fine :slight_smile:


#6

are the Selectors broken?


#7

yes all previous selectors are broken… any way to fix this?

My system security patches were updated yesterday, since then i am facing this issues.


#8

or Core.Activities version: 17.1.6522.14190 published on 18th. is there any way i can revert this to previous version?


#9

update your core activity to 18.1.xxx, restart the machine and try again


#10

it isn’t showing 18.1.xxx in available dropdown :frowning:


#11

not working fine!!! though now browser is opening rest of the steps are broken… Resolution please??


#12

Hey Support Team,

Still this issue is not fixed. i want a resolution.

  1. Previous recorded selectors are all broken
  2. Newly recorded selectors are way toooooo slow
  3. I want my previous recordings to work just like before, i have automated a lot i cannot go back and record them all again.(which is again way too slow).

UI Path: 2018.1.0
IE Browser Version: 11.1944.14393.0