Excel Delete Rows activity throws error 0x800A03EC

Hello all,

I’ve been running into this issue during one of my workflows where the activity to delete some filtered rows in Excel keeps on running into the same error (0x800A03EC).

In the flow, I’ve download an excel, opened it and put a filter on one of the date columns. After this, the file looks as follows:

The next action is to delete the rows that are now visible on screen. To do so, I use the “Delete Rows” activity:

However, this keeps on throwing the following error:

I have read somewhere that this issue could occur because UiPath wants to be quicker than Excel allows, hence the breakpoint at the “Delete Rows” activity. This doesn’t help.
Could somehow help point me in the right direction?

Thanks in advance,


Is it a xls file or xlsx?

Try with a xlsx and check if the issue persists

Alternately try using excel process scope and use settings like open as automation…not visible etc


How about reading the Excel file into a datatable, using Filter Datatable to get rid of the rows you don’t want, then writing back to Excel the entire dataset?

Hi Anil,

Sorry, I didn’t provide that information. It is an .xlsx file. In the meantime, I’ve also set the excel process scope to run as an automation. Sadly, the error persists.


Hi Paul,

I have thought about that as well, the issue here is that i’m filtering on the date. When doing so in a datatable, I keep running into issues with the American and European date systems. I would prefer to handle this through excel as much as possible.



Is it for only specific file?

Did you try resaving it with save as?


The problem does indeed only occur with these files (I download a new one within this flow every time).
Saving in between does not solve the issue.


Please try this…

Add the delete rows and filter in two different excel scopes and add some delay in between the scopes and check…

How big is the table?



I seem to have solved the issue. Sadly, none of the offered options worked and the same error kept popping up. What I have done now is inverse the filter, so that it showed the records I need to keep. Then I read the visible range to a datatable, cleared the excel-sheet, and wrote the dt back to the sheet. This both circumvents the issue with the filtering of dates in a datatable, and solves the error being thrown.

Thanks for the help, everyone!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.