Excel application error - Filter not working properly

excel
studio

#1

Hi Everyone,

This is my first time writing in a forum, please bear with me for lengthy note.

I have an excel containing 272 rows of which I need to apply a filter based on specific key words. I tried using “datatable.select” function which works fine up to 256 rows and for the 257 row UIPATH throws an error message as follows.

Assign : Min (257) must be less than or equal to max (-1) in a Range object.

Believe the issue with UIPATH is that, it doesn’t recognize rows ranges from 257 if any of the cell under particular column which is being filtered contains special character. (Ex: '0041).

I re-ran the studio by removing those cells having quotes and it works fine this time.
If this is going to be an issue then it affects our entire process.

Can somebody help me with an alternate way of filtering the datatable. Thanks in advance!!

/Aravinth. R


#2

Hi Aravinth,

Attaching your Sample Workflow on behalfSample.zip (15.3 KB)


#3

I noticed that column ‘A’ in my excel file contains value in both numeric and as well as string which was causing the studio to fail while filtering the data rows which has more than 256 rows.

I tried running the bot by converting the values as string by adding a single quote (‘) as a prefix and it works fine this time without any issues.

Hope this might be helpful!!