Error while running UiPath Deploy Task in Azure DevOps

I have followed this article exactly in order to setup CI / CD pipeline in Azure DevOps. CI pipeline works well but CD pipelines fails at UiPath Deploy.

Service Connection

Deploy Task

Below is the error that I am getting. It says that Orchestrator not found in Organization.

In fact, orchestrator is associated but we are running on Trial license of Cloud orchestrator at the moment.

Could that be reason for failure ? Please help me resolve this pipeline issue.


Did you create a tenant with name defaulttenant?

Can you please give the exact tenant name as per the tenanr name you created


By default, “DefaultTenant” was provided and I am using that only for now to check pipelines.


Please reconfirm the tenant name from
Orchestrator …looks like the tenant name might be wrong or the organization name might be wrong


Confirmed image

also Org name


And the orchestrator is enabled?

And if you have exactly followed the guide then you might need more scopes to deploy the package i beleive which are not mentioned in the article…

As I see only read access mostly and you would need pckages and process access to deploy

Try changing scope


I guess I am able to browse through orchestrator for Defaulttenant and have created modern folders within it suffice condition “Orchestrator is enabled”. Or do I need anything else to be done for the same ?

Regarding access I was not able to find any specific access for Process.

It would be great if you can provide sample access list.

Now I tried changing scope in service connection as well as included entire URL in Orchestrator URL as shown in below image.

Now I am getting different error as under.

1 Like


Can you show what you have in the package field of deploy?

Did you select the nupkg file?

And for access you might need robot,folder for sure and admin as well may be


In the package I have selected path of nuget package from the build pipeline.


Can you click on the three dots and celect the package and check if the path si changing


I tried it several times yesterday, path generated is same always.


As per error it is still not able to connect to the orchestrator…


Thats the same error that it gives always same at top but inner exception message reveals true error.