Error when opening Excel file (cannot contain newline or certain characters)

I am trying to open an Excel file from my files to create an automation on. But when I am using the Use Excel File activity to retrieve the file, I receive the following Error:

A file name cannot contain a newline, or any of the following characters: * : ? " < > |

But the issue is, my file name does not contain any of those characters and if I try to use another file (also without those characters) it still gives the same issues. I’ve tried everything but can’t seem to figure out what I am doing wrong.

@oaarohansen - Please share the screenshot of the workflow and the file saved in your folder(i.e. trying to open)??

1 Like

Not sure how to add, but here goes:

And the file

@oaarohansen - Hmm…Looks like whatever screenshot you have shared , all look good…but this.


I see an error icon here. May be one of the activities is throwing this error ??

It is definitely one of those activities, I just can’t seem to understand why it is happening. The path has no characters that would interfere with the opening of the report.

@oaarohansen - Click on the + Sign near the folder icon and choose open advance editor…



which will bring it to the below screen…

Could you please share , what you are seeing there?

Here you go!

@oaarohansen - Looks good very strange. Could you please copy that file to the project folder path and give it a try once. Just for debugging purpose…

That does eliminate the problem! Do Excel project files need to be within the project folder?

Good to know…

Nope… This is just for debugging purpose i have to asked to try. This proves that the excel file name is not the culprit. So I believe this has something to do with the folder path.

Gotcha. Could it be something with it being within OneDrive or Sharepoint?

May be or May not be, since I have tried both I can’t be sure.