Error Uploading file to sharepoint

Hi, I was using Microsoft 365 Activities to upload files to SharePoint with Azure Tenant and ID and applications ID. I get the following error with (drive) upload-file activity. Any ideas how to solve this ? (public-key is hidden)

Upload File: Method 'DisposeAsync' in type 'System.Text.Json.Utf8JsonWriter' from assembly 'System.Text.Json, Version=, Culture=neutral, PublicKeyToken=xxxxxxxx' does not have an implementation.


UiPath Microsoft 365 - v1.11.1 (works)
UiPath Microsoft 365 - v1.14.1 (problem)


I get the same error. Help!

Most likely this happens because you have an incompatibility between the Mail package and the O365 package.

The root cause is a break in compatibility in the underlying Microsoft Graph Client library (not caused by us, but by Microsoft). The older versions of Mail/O365 use an older client, the newer ones use a newer client that is unfortunately NOT compatible with the older ones in terms of API.

I would try to upgrade tot the latest mail package, that should use the same Graph Client as the latest O365 package and the problem should go away.

Do we have any other solution for this? Also encountering this one when I moved my code to our server. It was working on the dev machine all right. I tried updating the Mail and O365 to 1.15.2 - included the preview too. But still the error persists.