Error Opening Workbook (no Excel installed)

I keep getting the error “Error opening workbook. Make sure Excel is installed” when I try and open an Excel application scope - even though I have unchecked the ‘visible’ checkbox. I thought if the visible checkbox was unchecked then excel did not need to be installed ? Or am I wrong about that…? Thanks :slight_smile:

1 Like


If Excel application is not installed then use Workbook activities and it will work for sure.

1 Like

Thanks. Got it working now (sorta). I didn’t realise you couldn’t use the Excel application score without excel installed. I thought if you deselected the visible checkbox you could use it without Excel - guess not! Thanks though :slight_smile:

1 Like

No worries
Fine let’s go one by one

Usually this error occurs when there is not Excel application is installed
Kindly check once whether the excel in our system

VISIBLE property is like when it is enabled it will bring the excel application opened up,thus bringing to the FOREGROUND of the screen
So the excel will be visible in the screen in the front replacing all the application as a background running application

So VISIBLE property is to decide whether to bring the application foreground or not
And that doesn’t meet the application installing criteria

Generally excel application scope when used our machine must have application installed
Or we can either use other options like workbook activities In the activity panel which will have the same set of activities like how we have in excel activities

So no worries we can use that option.

Hope this would help you
Cheers @adam.williamson

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.