Error in export extraction results activity

Hello all.
I am using Export exrtaction results activity in DU.
But getting below error.
Export Extraction Results: Object reference not set to an instance of an object.

outputdata type is Sysyem.Data.Dataset (1.3 MB)

Hi @Dinesh_Babu_S ,

Most probably the Error is due to the extractionResult variable value being empty.

Could you Check the Count of the field values present in extractionResult varaible ?

We can do so by using the Write Line or Message Box with the below Expression :


or We could use a Breakpoint at the Export Extraction Results Activity and then Perform a Debug and Check the extractionResult value using the Immediate Panel.

Let us know if you have tried this out.

Thanks @supermanPunch
I’ll do that and confirm it.

1 Like

Hi @supermanPunch !
I tried your solution. Its giving empy results.

I’ve also tried to use this code in write line activity.
Gettitng error: extractionResult.GetSimpleFieldValues.Count(string) is a method, which is not valid in given context.

@Dinesh_Babu_S ,

The Suggested method was not a Solution, But a method to find out if the extractionResult is really empty.

Have you entered the extractionResult variable in the Immediate Panel and got the Result ?

Based on this Output, If the extracted data is empty, it would mean that the data was not able to be extracted properly and we would need to Check the Data Extraction Scope configuration or if a Validation Station is used, we would need to Check if the contents are getting extracted in it.

Immediate Panel after entering the extractionResult should contain data similar to the image below :

If you can get the FieldId value from the Taxonomy or from the immediate output from the extractionResult, we can Check if there is a Value for that field using the extractionResult variable :