Error data scraping y find element

Estoy ingresando a una pagina para guardar ciertos datos pero no logro mi objetivo. Lo he hecho de dos maneras, a través de Data Scraping y Find Element pero al hacerlo de estas formas pasa lo siguiente, al ejecutar con Data Scraping devuelve el resultado vació, pero si pongo un punto de interrupción y voy revisando paso a paso el resultado viene con información. Al ejecutarlo con Find Element, devuelve la información pero el primer dato viene vació. Alguna vez te ha pasado esto o sabes si alguien ha tenido algún problema similar, la verdad llevo varios días leyendo e intentando ver que puede estar fallando pero no he logrado encontrar el problema. Bueno desde ya muchas gracias.

Cuando usas data scrapping te devuelve algo en le preview?
Por ejemplo cuando uso en amazon me muestra la imagen
image

.

Hola @matiasarr, Si, me devuelve el resultado de lo que esta en pantalla, luego lo envió a un Excel Application Scope para guardar los datos pero al revisarlo viene vació.

Ok, tiene mas de una pagina?

Solo una pagina

Cuando te pregunto si tenia mas de una pagina le diste a si o no?
Podes compartir el codigo?

es solo 1 pagina, le di la instrucción de no. Es extraño, porque ya he utilizado Data Scraping anteriormente sin problemas, al igual que Find Elemente, pero esta pagina en particular me trae estos problemas

Puede ser que cargue muy rapido la pagina y no este levantando datos? podes ponerle un delay antes de el data scrapping?

Era eso efectivamente, la pagina tarda mas de lo normal o por lo menos mas de lo que había visto hasta ahora, con un delay de 10 segundos toma todos los datos. Muchas gracias por la ayuda Matias.

Dale, yo uso un element exist completed de algun item , eso capas te puede ayudar