Error connecting to sftp

ftp
activities
error

#1

I’m trying to connect to an FTP site using the open FTP activity. As far as I can see the credentials/connection string and port are correct - I can connect via filezilla. The connection uses a key file and no password. I tried setting the password to a blank string and leaving it empty but no luck - still the same error. The username is set correctly.
I get the error below though

Renci.SshNet.Common.SshAuthenticationException: No suitable authentication method found to complete authentication.

Server stack trace:
at Renci.SshNet.ConnectionInfo.Authenticate(Session session)
at Renci.SshNet.Session.Connect()
at Renci.SshNet.BaseClient.Connect()
at UiPath.FTP.Activities.FtpSessionGen.Connect()
at UiPath.FTP.Activities.OpenFTPSession.ExecuteAsync()
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)
at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)
at System.Action.EndInvoke(IAsyncResult result)
at UiPath.FTP.Activities.OpenFTPSession.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.FTP.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
caseflow New Business upload execution ended

any advice on how to resolve?

thanks


#2

may actually be an issue building the connection string using the parameters provided

‘DynamicActivity’: The private implementation of activity ‘1: DynamicActivity’ has the following validation error: Compiler error(s) encountered processing expression ““C:\uipath\keyFile.ppk”)”.

End of expression expected.

There are no errors when validating


#3

There is a bug in FTP activities when using sftp with key file. I submitted a bug report to UiPath about it. Now we just need to wait them to fix it.


#4

thanks ottojuntunen,

I used start process, batch script and winSCP to work around in the meantime