Error: 80040154 class not registered after every restart on Citrix-PC

Installer(.exe or .msi): Uipath Studio.exe

License type(Free, Trial/License code): Studio and Unattended License

Studio/Robot version: Studio 2018.4.5

Current behavior: Works but only if I delete the .nuget folder


Hello UiPath Users,

I’ve following problem: Our robot is installed on a Server. On this Server, several users can login and are able to use UiPath. But our problem is, if we logging out of the Citrix-Server and login we can start UiPath but can’t run it.
The error 80040154 class not registered occurs and we can only proceed if we delete the .nuget file in the folder c:\users\user-number → delete .nuget file. After that everything works normal. Our problem is that we don’t want to delete the .nuget folder all the time since we want to use the robot on two different Pcs. One is the developer Pc (Licensed) and the other one is an unattended License (UiPath Robot).

Do you guys have any idea how to solve that problem quickly? I tried to delete the folder, tried to copy the folder and use only this .nuget-folder with the “correct” settings.
It only works if I do following procedure:

  • open UiPath Studio / UiPath robot → go to c:\users\user-number → close uiPath studio / robot → delete .nuget-file → open uiPath sutdio / UiPath robot again.

thank you very much in advance.

Best regards

Hi @Henne1992

I have seen this issue a few times on the Forum but the only solution so far was indeed only to delete that folder.

I can see you are using the Enterprise edition. Would you mind contacting our technical support to register the issue in our system. It will both allow us to track it better and hopefully get to the core of it. See the form here:

Hello loginerror,

I’ve contacted UiPath. Thanks for the formular.

They gave me following manual to solve the problem:

Step 1 :

  • Open %userprofile% in your affected Robot system

  • Navigate to “.nuget” folder.

  • Take a backup of the “packages” folder to a different location.

  • Delete the current folder in .nuget location.
    Reason: This would delete all the packages thus allowing to Robot to download the packages again when a process is executed.

  • Now download & execute the process from the Robot tray / from Orchestrator.
    Reason: The process will download again with all the required dependencies.

Now launch Studio again & verify if the issue persist.

Step 2: (Implement step 2 in case 1 fails)

  • Identify the UiPath.UiAutomation.Activities version which is currently Installed / used in your system.
    For Example:
    If the current installed version is 19.4.1 than upgrade to the one of the later version e w.r.t he installed i.e. 19.4.2
    In case issue persist with follow the same and install 19.5.0

Likewise, verify the UiPath.UiAutomation.Activities package which is compatible to with your environment & application you are automating on.

  • Select the version → Update → Save → Restart / Relaunch the Studio.

Step 3: (Checking User permission)

Kindly try the below steps:

  1. On execution we will face error related to the class registration error.
  2. Navigate to the UiExplorer location
    C:\Users\user profile.nuget\packages\uipath.uiautomation.activities\19.5.0\build\ UiExplorer
  3. Launched explorer.

This will conclude that if the user does have enough permission to execute the required .dll & .exe file.

I did 80% of those steps already. But unfortunately, this doesn’t solve my problem with the .nuget-file.
Our Server still creates an .nuget file which can’t be used.
But if I use the copy from the deleted and restarted UiPath-Studio it works.

So what I’m doing right now is to copy this “new created” version of the .nuget-File every time I restart my Pc and login to the Citrix.

If anyone has a good workaround for that copy+paste problem please let me know.
Meanwhile I’m waiting for another respond from UiPath. Thanks.

Any reasons to this? It seems like it is an unpropper installation.

I have the same issue --’ Any Updates ?