Error 403: access_denied

Dear all,

It is the first time I am automating with GSuite, and I am facing an error of access_Denied:

" Error 403: access_denied

The developer hasn’t given you access to this app. It’s currently being tested and it hasn’t been verified by Google. If you think you should have access, contact the developer"

I have created ID credentials in Google Cloud Platform, and paste them inside GSuite Scope activity. After that I have copied the ID from one worksheet I have in my Google Drive and pasted it in Read Range activity for GSuite scope.

Why is this error appearing?

Thanks :slight_smile:

You confirm you added the same service account as that of which you logged on to the chrome?

Have you created the service account yourselves? If yes, probably there is some things to check

Go to GCP console and follow the below steps

  1. Go to OAuth consent Settings
  2. In Process users → Add Users
  3. Add the users for the Process

Even if you are the owner and not able to access, just add your user there and check

1 Like


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.