Downloading File using Chrome giving error

I need to download a xls file form a website but while downloading the file I am getting an error.
How to resolve this issue without UI Interaction to add a click element for “Keep”?
Thanks in advance!!

Hi @Kunal_Jain

After giving click on Download button. Use check app state activity and indicate the popup.
In Target appears block give the click activity and indicate the keep button and don’t give any activity in Target does not appear block.

When bot hit on download button if this popup appears then only it will click on keep or it will go for the next activity.

Hope it helps!!

Hi @mkankatala
If I don’t get the pop ups than what I am supposed to do?
Because for some machines we have disabled the pop ups.

That’s why we used check app state activity, this helps to check the popup is there or not on the foreground if it is there it will go to Target appears block and execute click activity to click on the keep, don’t give any activity in Target does not appear block.

Check the below image for better understanding,

Hope you understand!! @Kunal_Jain

Hi @mkankatala
I understood what you are trying to say but the point is if we do not get pop up and the downland is blocked in that case what are we supposed to do?

How could we know the download is blocked manually. @Kunal_Jain

Hi Anybody solved this issue ,I am facing similar issue where chrome is blocking the file from download

Hi @ridaydesale & @Kunal_Jain

Because of the new chrome update which blocks the downloads from the unsecured sites (which don’t have https) unless you click on the keep button in the downloads section.

We face the similar issue you can solve it by following these steps in this article

Hope this helps :slight_smile:

Thanks,@AJ_Ask , for the help , In this case it can only avoid the warning message as per the settings in the Chrome flags. in my case i still want to download the file so I have workaround for this issue where i am renaming the blocked file with desired extension and it is working as of now. hope it helps

You can also whitelist entire websites via Chrome’s settings:

  1. Settings > Security and Privacy > Site Settings > Insecure Content.
  2. Under Allowed to show insecure content click “Add” and enter the main website URL and click “Add”.

Issue Solved

1 Like

I am able to DISable this via flag chrome://flags/#insecure-download-warnings

First ‘Enable’ - Temporarily unexpire M120 flags and relaunch chrome.

Then ‘Disabled’ - Warn on insecure downloads and relaunch chrome.