Download file from internet with "HTTP Request" activity - Job stopped due to unexpected process termination

I’m trying to download a large file from internet (>200Mb) with the “HTTP Request” activity and I’m getting this error:

Message: Job [my UIPath process] stopped due to unexpected process termination"
Exception type: Exception

Does anyone now what is happening and how can I solve it?

My workflow only has that activity (later I would like to do more things, but this is the first step).

I have read in this thread that I have to configurate the maxReceivedMessageSize attribute, but I have no idea about which size I have to configurate there and if someone had the same issue and if it was solved doing what is said in that article.

Any recommendation or workaround?
Thanks in advance

I had the same error trying to change characters in a big file with the replace (.net) function in a .txt file larger than 1Gb.

@rodrigo.garcia - As indicated in the links in your post, did you change the size to 1048576?

Also,

  1. Check if you are using any WriteLine and comment it out.
  2. Change the robot logging in Orchestrator from Verbose to Info.

Try these and see if it helps!

I don’t have in my filesystem the file indicated in that article or at least, I can’t find it. About the other suggestions:

1.- I don’t have any writeline, I just have the activity HTTP Request in order to test how to download files. I have checked the same activity with a smaller file and it works well.
2.- I’m just using UI Path studio, I don’t have Orchestrator, or at least I don’t have visibility of it.

I think the problem has to do with the size of the file

@rodrigo.garcia - What is the version of UiPath Studio you are using? I am using 19.1.0 and I could find the file in the below location and the value was already set.

C:\Users<user-name>\AppData\Local\UiPath\app-19.1.0

Could you please find the file “UiPath.Service.Host.exe.config” in your computer and see what is the value set to?

My UI Path versión is 2017.1.6435, in the future my company will upgrade it but it’s what we have right now.
About the file, it isn’t in my computer, I will ask IT people about that file and the problem I’m having.

Hi rodrigo,garcia,

Has this been resolved already?
We are having troubles in this for two weeks,
Pelase kindly help if you have any insights or such.

Many thanks,

by the way, please let me copy you thread and post since we are faced with same issue.