Desktop application not getting opened in Picture-in-Picture

Hi all, I am not able to open a desktop application in PIP. The application is successfully getting opened if I run it without PIP but when ran it in PIP, it throws the error that selector not found. Attached is the screenshot.

2 Likes

Hello you have to first set up an Environment variables on your system so that the PIP window has enough time to open.

Your selector shows that Chrome window has not opened.

So,

First set the environmental variable and then run the application in PIP. Allow PIP window to fail. Take control of PIP Window and then open Chrome inside PIP and make sure the UiPath plugin has been enabled.

Now run the automation from studio.

It should work unless your selector is wrong.

Refer to this link to set the variable:

@AndyMenon What is the path value that you need to set in the variable? I can’t see it anywhere mentioned in this post. It only says the name needs to be UIPATH_SESSION_TIMEOUT. Also it is not a web browser test that I am running. It’s a desktop application test so it needs to open the application instead of browser.

You have to set it as an Environment variable in your computer properties.

It is not a path, but a numerical value in seconds.

I set the environment variable and value to 30s but still it doesn’t open up the application and I get the same error. It opens it fine without PIP.

You might want to set it up for a higher value first. Maybe 300s. The first time is always a pain.

Also, did you run it in PiP using Debug mode? Does it work correctly when you do that?

The specific desktop application is getting opened outside the PIP window and not inside the PIP window. All other applications are getting opened inside the PIP window. Has anyone came across this issue and knows how to fix it?