Delete Folder - Access to the Path Denied

Hello Team,

We are facing 1 issue in deleting Folders from a Shared Folder Path.
Service Account used by the robot has given Permission of - “Full Control” to the Shared Folder Path, yet Delete File activity or Delete Directory method throws Error as "Access to the Path xyz/…/abc is Denied.

We are able to delete the Folder’s manually (using the same account which robot is using). Also robot is able to delete Folder’s which are created by robot or human in Destination Path. But not the One’s which are Moved from 1 Source Folder to Destination even though the full control is given to it.

Please help in resolving this issue !!

Thanks & regards,

Hi @rohith.prabhu ,

Try running Studio in Admin Right and try to delete the file.


Tried, it didn’t work.

Hi @rohith.prabhu …Just couple of questions…

  1. Is this is the first time you are facing this error? or Did this process worked before?
  2. Who is doing the below job? System or Manual?

But not the One’s which are Moved from 1 Source Folder
3. Did you find any differences in the access which robot is deleting Vs not deleting?

my guess is , some access is getting changed during the copy/move…

Hello @prasath17

  1. Yes, this is the 1st time we are trying to delete so facing it 1st time.
  2. System (Robot is moving/Copying Files after Processing it Successfully from 1 folder to another)
  3. Yes, One observation is robot is able to delete folder’s which has files in it and throws exception as access denied for the empty folders. (Throws for root level, suppose xyz/abc/def is the structure, and def is empty robot will not delete any folder’s).

Access i have verified manually in destination and it has full control after copy/move.

Thanks & regards,

1 Like

Can we safely say , the problem is with *deleting the empty folders only ?

Because folders with files inside it are deleting (verified with multilevel folder structure works fine.
Ex: MOP/def/Files
MOP/abc/Files - are deleting at MOP level, but

MOP/abc/empty - throws error as access to the Path MOP/def is denied.


Try adding delays before each delete. I’ve seen issues where the process runs too fast. Put 50p ms delay before the activity.

It is not related to delay, because i have Provided single folder path to Delete activity and Access denied Error is popping up.

Can you share screenshot(s) of the work flow? It would be helpful to see the process that is occurring for the 5-10 activities before.

If you run in debug mode and step thru each activity, do you get same issue?

Maybe out of the question, but instead of moving the files what about strictly copying the files to the desired location and afterwards have the bot delete the original destination folder. This would eliminate an empty folder during the deletion process.

Could you please enable continue on error in properties panel, hope It would helpful.