Database Connect Activity Broken when Migrating to Windows activity

I recently converted my workflow from Windows - Legacy to Windows to comply with the warnings about things not working soon. Once converted, when I attempt to debug my workflow (which includes a DatabaseConnect activity making a connection to an Oracle database) that gives me for the following error:

Bad IL format. The format of the file ‘C:\Users\ROADMINASS.nuget\packages\UiPath.database.activities\1.6.1\lib/net5.0-windows7.0/runtimes/win-x64/native/sni.dll’ is invalid.

I currently have 1.6.1 version installed for UiPath.Database.Activities, but I have upgraded and downgraded to versions 1.7.1, 1.6.0, and 1.5.0. All of these have provided me the exact same error code when debugging the workflow.

How can I fix this? I’ve even deleted those folders out of the .nuget folders to attempt to reset things, but to no avail. Do I need to change the Provider Name to something else? I’d prefer to stay with Oracle, but need to make this connection.

Picture of DatabaseConnect activity below with my settings:


I have the same issue :frowning:

Same here, I don’t know what to do , tried a lot of things to make it work but it was not succesfull :frowning:

I seem to have the same issue, Any advice?

Having the same issue on multiple projects!!!
Assistance needed @loginerror and all other tech wizards from UiPath

Having the same issue as OP, and have tried the same things. Reached out to UiPath Support and it seems to be an error/bug that is still without a resolution.

The interesting part for me is that I’m able to connect to the database from my machine but an unattended bot cannot.

So far I have been given 3 hits, none work but i’ll share here since this might be a multi-issue problem and some of the solutions work for some and not for all.

Install/Check Microsoft Visual C++ 2012 Redistributable ([x86|x64]) in your apps & features/installed programs.

Solved: Re: Microsoft.Data.SqlClient custom action fails to load dependency. - Community (

SqlClient troubleshooting guide - ADO.NET Provider for SQL Server | Microsoft Learn

Please let me know if anyone finds anything else that might be able to help me.

Thank you,

Hi @taxguy33

Just a thought - could you please test out if the same happens for you for an MS SQL Database?

And a follow-up thought after short research → is your Oracle driver available on the machine for win-x64?

1 Like

Testing a connection with the MS SQL database is irrelevant for my situation, as the Database is an Oracle Database and I would never be able to make a successful connection with anything other than Oracle drivers.

I’m a bit of a novice when it comes to Oracle drivers being available on the machine. When I made the connection on Windows - Legacy protocols, I didn’t do install anything other than choosing the Oracle.ManagedDataAccess.Client provider name and the connection was able to be successful. Do you have suggestions on how to check if the Oracle Driver is available on the machine for win-x64? I took a screenshot of my ODBC Data Source Administrator (64-bit) screen if that helps at all.



Hi Maciej,

Good guess on the driver, for me it was that the issue. Never thought of checking the version because we have been using the 32 bit with legacy and it was setup a long time ago.

Did this just happen to be the case with this activity set (UiPath.Database) or are generally all newer activities Net5+ using 64 bits as a default? Just curious.

@taxguy33 I have mine setup on the System, however I use the Oracle Client 19c at the machine level. Might not be your setup. Oracle Database 19c Download for Microsoft Windows x64 (64-bit)

Hope this helps anyone else.

Thank you,


1 Like


It might be, although I am not 100% sure. But for Database package yes.

1 Like