Database activities Execute Non Query failing, query '' corrupt

Hi,

I’m experiencing the following issue with with the database activities, specifically Execute Non Query.

A colleague created this code and it uses the database activities to setup a connection to an excel file and query the excel file as if it were a database. This has worked correctly for a long period of time however it has started throwing errors.

I have the following query in the activity
"Update [ALL_GENDER$] set [Disability?] = 'N/A' Where [Disability?] IS NULL"
where All_GENDER is the excel sheet and Disability? is a column heading.

As I said, this has worked without any issues for a long period of time however I’m now getting the following error
Query '' is corrupt.

I haven’t used these activities before so any suggestions or help would be greatly appreciated.

Hi
this is something related to your database and not with UiPath

I hope Patches for this bug have been released
kindly check once with your admin team on this to upgrade to latest version
Cheers @ConorSmalley

So this could be resolved by updating to the latest version of the package?

hmm…lets do one

kindly run the same code in your database server and check manually once whether this statement is working or not
based on that we can validate where is the issue

Cheers @ConorSmalley

There isn’t a database server

we would have connected to a server…na
i hope we can run this sql statement over there
Update [ALL_GENDER$] set [Disability?] = ‘N/A’ Where [Disability?] IS NULL
@ConorSmalley

As in my original question this database connection is connecting to an excel file not a Database Server

1 Like

oh sorry that was my bad…i didnt see that
Fine
try once upgrading the database package
@ConorSmalley

I have just checked and the code is already running the latest version of the database activities
"UiPath.Database.Activities": "[1.2.6863.32528]"

After investigations it appears that this is a known issue that is caused by MS Patches

A fix is known and available for MSI office installations however a fix isn’t yet available for C2R installations, the solution for this at the minute is to rollback the patch

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.