Ctrl + c hotkey combination not working

Hi,

I selected a range to be copied in Excel. Ctrl + c send hotkey activity was working perfectly fine but I am running into issues now and the clipboard doesn’t seem to have the data which was copied.

Hi,

You can use the read range activity and set a specific range, it’s the best way to extract data from excel, no need to use hotkeys

Marcelo,

I don’t want the data to be read into a data table. I need to copy it on the clip board because it needs to be pasted into another application.

@meghna.b.das - Can you please try this outside of Uipath.

Copy anything first…and try windows+V(Clipboard paste)…when you hit this key it will show the list of all the items copied…

Like this…

This way , first you can make that you items are captured in Clipboard.

Hi @meghna.b.das did u use Ctrl+C or Ctrl+c?

@meghna.b.das

Just enable SendWindow Message then u will able to copy.

1 Like

Hi, I did a select range for the Excel range and sent the hotkey with SendWindowMessages selected in the property but it seems to be copying only the first cell. For example, I selected range “A2:E3” and sent ctrl+c. But it only copied and pasted A2.

@meghna.b.das - I dont think select Range will copy all the items to clipboard…

I just tried to check this…

And the output I received is

image

So you have to pass the write key strokes to select that range…

Please check here…please download the sample at the bottom and check …

@meghna.b.das - Here you go …I have tested this and working…

  1. Excel application scope
  2. Use Browser/application
  3. Keyboard Shortcuts…
  4. Get From Clipboad
  5. Message box

Output

Note:

To get Keyboard shortcuts and Use application/browser activity, go to settings --> Design --> Turn on “Use Modern for new projects”…

@meghna.b.das - did you get a chance to try ? If so, please mark as solution and that will close this thread.

Thank you @prasath17 . This worked out perfect :grinning:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.