Critical error when connecting MS Access database

Hello team!
I’ve been trying to connect a MS Access database to the process I’m working on, but every time I open the wizard it crashes and gives me an critical error message. Even if I just leave open the wizard without doing anything, it closes the whole thing. If I am quick and make the connection, still, will give me the error afterwards. This ONLY happens with the connection database actions, always. Is there something I need to uninstall? This is what I get:


Studio closed the active project due to a critical internal error. You may retry to open the project.

Error: UiPath.Studio.Contracts.RecoverableException: Studio closed the active project due to a critical internal error. You may retry to open the project.
at UiPath.Studio.Project.Client.Ipc.Services.ProcessTerminatedBehavior.HandleProcessTerminatedInternal()
at UiPath.Studio.Plugin.Workflow.Services.ProjectProcessController.b__19_0()
at System.Threading.Tasks.Task.<>c.b__128_0(Object state)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler), HResult -2146233088

I’m new to UiPath, so even when I try not to use the wizard and input the connection string the same as the wizard showed (Provider=Microsoft.ACE.OLEDB.12.0;Data Source=“C:\Users\USUARIO\Desktop\UiPath RPA\Database.accdb”), it gives an error processing the expression (I’ll paste a picture below). It doesn’t seem to crash when I input the connection string directly on the connection configuration but I don’t know to to properly create the connection then.

I’ve tried uninstalling and installing the package, using an older version, creating a new process, but I don’t know how to fix this… Any guidance is much appreciated!

I’m guessing I’m not properly connecting the provider to MS Access?

Can someone please tell me how to create a connection string, please?

Hi @Laouns

check this post, try to use UiPath Diagnostic Tool to further identify the issue

hope this is helpful


Please check this link …this would have all connection strings…please use accordingly

Hope this helps

Alternately try changing the pckage varsion and check if problem still persists with wizard


I’ve seen that post… no solution there :frowning:

I tried installing an older version but error persist. Thank you for the link. Will check that right away…

1 Like

You put your connection string as: Provider=Microsoft.ACE.OLEDB.12.0;Data Source=“C:\Users\USUARIO\Desktop\UiPath RPA\Database.accdb”

The entire string should be in quotes as follows: "Provider=Microsoft.ACE.OLEDB.12.0;Data Source=C:\Users\USUARIO\Desktop\UiPath RPA\Database.accdb”

I just created a sample Access DB and used the wizard to connect, run a query with no issues. My connection string was similar to yours except for the quotations.


1 Like

Thank you! Yes, I did add the quotation marks… I was confused and thought there was a mistake since the red flag did not go away, but I will try to run it as it is!


That is probably because of the double quotes…inside the double quotes if you want to escape a double quote you need to use double of that…i…, if you have one double quote escape it with two

So say string is Text…ideally you would pass "Test"

But if there is a double quote in string like this Te"st to escape you have to pass "Te""st"

Hope this is clear


Good to hear, glad you got it working. Can you please mark reply as solution? Thank you

Sorry about the question, but… where do I change the status? I’ve been trying to update it with no luck

I think it is an option at the bottom of the reply that was the solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.