Create file with UTF-8 without BOM

encoding
file
activities
studio

#1

I am trying a create a new file by Create File and Append Line activity. But the issue is it is creating a file with UTF-8 BOM encoding which looks fine in normal editor. But if you lookup that file in Hex editor, it has 3 extra characters at the beginning which makes it unusable. How can I create file with correct encoding UTF-8 without BOM? The Encoding property in Append Line is not helping.


Write CSV as CSV instead of CSV UTF-8
#2

Hi @pratikindia
If you set encoding parameter “” instead of “utf-8”, the output file is encoded utf-8 without BOM.


#3

I tried “”, it does not work. I fixed the issue using PowerShell script.


#4

It’s strange.