Could not Read Range for Excel File (895.3 KB)
Attached is my file, I tried to read range but not sure why it return an error of ‘could not read range’. May I know what is the issue causing my data to be not readable?

Checked your workflow. Try to select the option “Preserve Format” and run.

I tried with Preserve Format Option , same issue…

I was checking with file, i first though that since it is very large file, may be it would be the reason for the error, but when i tried to use the database activity to consider excel as database, it is still throwing same,

When i tried around 10000 first rows, it works fine, and between 15000 to 17000 rows it is working fine, but when it comes in between 10000-12000 it is throwing the error [ from my intial observations]

@JasonJC , let me check more and get back to u

Nived N

I tried formatting the dates to general, it will be able to read the file. However, I need the date to remain as short date for other parts of the RPA.

That’s weird. Ideally not suppose to happen that. Let me check again to the faulty range you mentioned.

Hi @JasonJC

  • You should update the Uipath.System.Activities
  • Your Excel may be corrupted. so Check the Excel file and check
  • For me, it’s working good.

Hope it will solve your query


I have updated the excel packages, I copy the data to a new excel file and still could not work.

Hi @JasonJC
-For me, it’s working well with your excel file
-You can check with a different Excel file with a dummy record


Other excel file using dummy data works, this excel file data is extracted from a list of bank statement workbooks where I read range and merge it together to get this output file for easier extraction of data. I only change the value to be shared here for testing. I have data from different banks, but the could not read range error is inconsistent. What I don’t understand is why if in general format, it will work. But when it short date format, the data could not be read. Thanks

1 Like

Hi @JasonJC

If you convert the dates to text format

Did it work ?

I require the file to to be in short date format because will need to match the data with other data through the dates in my other automation process. If in text format might not be able to match correctly

Hi @JasonJC

What i am suggesting is convert the dates into text format in excel for [for testing] and try to read again.

I hope it will nullify the error

Nived N

I have tried to use workbook read range instead of Excel read range, but it happen with same error.

then I have used 2 read range activities, 1st for the range A1:G10000, no issue, 2nd A10001: G11001 read range got error.

then i disable first read range, 2nd read range for A10001: G11001 still cannot.

@Gokul001, I am using Office 365. Uipath community latest version. still cannot.
is my notebook not good as yours? :grin:

Check your excel file column types for all the columns, especially date columns…if the values in date column are of string or any diff type we get this issue…so check all the columns once.

yep you’re right, I had the same issue and looked through my data and found a formula within a column with only dates, deleted the formula and the activity worked smoothly after that. :+1: :+1:

1 Like