Could not Read Range when reading a range I just wrote

Hello, any help would be greatly appreciated. I am running a process that reads a range from a csv, then writes that range to an xlsx inside and excel application scope. I add some columns and formulas and read the range again, filter it, and write that range to a new tab in the same workbook. From there I filter the data again based on a new formula and read the range again. This is where the process is failing due to the format of the data I just wrote from the first xlsx tab.

When Initial wrote from the csv the data looks like this: image
Then after reading this range and filtering, it gets written like this: image

This format and the infinite #### signs that are in the cell no matter how wide I expand it are causing a read range error.
Read Range: Could not read range A1:H20.

I have tried both excel application scope and workbook activities and I have tried with both preserve formatting checked and unchecked and I can’t seem to get this to work.

Please help!


Can you try to output data table activity to view what is getting output from CSV file?


Hello @Srini84 , thank you for your reply. I think I may have solved the issue. The format of the cell I was writing to was in a date format. I am re-using the the same sheet after adding columns and I found that using delete range at the end of my process was eventually shifting a date formatted column over by one until it hit the integer column after 2 or 3 runs through. Solved the issue with changing the clean up activity to remove columns instead of delete range.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.