Could not parse Microsoft Excel version

Hi everyone!
I got an exception I haven’t found referenced:

System exception:
Could not parse Microsoft Excel version: $

I cannot find a reference to this error, it seems a leak memory from Excel (0X00… like) but I get this error message instead. I solved it by going back to old guard methods :sweat_smile:

I happened when trying to open and close same excel file to get different sheets in a For Each loop.
Im Using Excel Scope, assigning Workbook variable and closing it after each extraction (Excel application scope, Read range, Colse Workbook)

Right now, I’ve solved it by adding a delay of 2 seconds after Close Workbooc activity, I know it’s weird but it works.

I hope it can help someone, welcom anyone who wants to take the lead

Have a nice coding!

Hi @jmedinacarbonell try using workbook activities instead of application scope and things will work fine.

Hi and thanks for your help,
I forgot to tell it but, I had already tried this solution and … It throws errors, which seems normal since it has hidden sheets and Pivot Tables.
You can check this out : WorkBook Read Range: Index was out of range. Must be non-negative and less than the size of the collection.Parameter name: index - #9 by pakankshabha
Only way to manage today I found is by the method described

I think yours is a good approach, I recommend to try yor solutions first and, if it doesn’t work, mine :slight_smile:


Any chance you could create a sample fresh project that reproduces this issue for you 100% of the time? That would help a lot :slight_smile:

Hi, I haven’t forgot this, I’m just trying to find the point to externally reproduce it, let me show you why:

  • Look-like:

  • I’ve recently discovered that its just happening when running the process from Orchestrator, It doesn’t come in my dev env

  • As said, it’s only solved (just in my case) by adding 3s Delays between them like:

I still think that must be a good a pproach to aim @shetanshudhar solution first, it’s working normally and then, if need so, attack it like this.
It happened to me in 2 more projects lastly.


The mention of 3 seconds does ring a bell. Could you try with the latest Excel activity package? There is now a new property called InstanceCachePeriod of which default value is 3000ms, see more here:

It looks like our team has already made an attempt to resolve the issue :slight_smile:

1 Like

That sounds really good, Cheers!
Could you specify since which version of Studio do we have this new feature available?
I just checked my case, we have 20.4 on premises and I’m already targetting to the max Excel.Activities version, 2.8.6.
I can’t find in releases page when it came.

1 Like

I took these screenshots on 2.9.3.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.