Could not load type 'System.Activities.TextExpressionBase`1' from.....Error running unattended robots from orchestrator

I have been getting a System.Activities… error(full error below) when trying to run a project I published to orchestrator unattended on VMs.

Some considerations: I sent my project as a zip file to my coworker, and it ran successfully when he published to orchestrator and ran it unattended himself.

I published a different project to orchestrator, and it ran unattended successfully as well so it can’t be a compatibility error b/n orchestrator and studio.

I have tried editing and deleting the json file of my project and publishing but that didn’t work as well.
I have also tried reinstalling all the packages/dependencies, making a copy in a different project nothing seems to work whenever I upload it.

Any help/information on this issue would be highly appreciated. Thanks!


Could not load type ‘System.Activities.TextExpressionBase`1’ from assembly ‘UiPath.Workflow, Version=, Culture=neutral, PublicKeyToken=null’.

System.TypeLoadException: Could not load type 'System.Activities.TextExpressionBase1' from assembly 'UiPath.Workflow, Version=, Culture=neutral, PublicKeyToken=null'. at Thrivent.TestCases.THRIVIGO_51873.Thrivent___Headless.GetImplementation() at System.Activities.Activity.OnInternalCacheMetadata(Boolean createEmptyBindings) at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors)
at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack1& activitiesRemaining, ActivityCallStack parentChain, IList1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback)
at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors) at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)
at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.WorkflowApplication.EnsureInitialized()
at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push)
at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout)
at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state)
at UiPath.Executor.RobotRunner.RunWorkflow()

Hi @anan.deneke

The error you’re encountering, Could not load type 'System.Activities.TextExpressionBase1' from assembly 'UiPath.Workflow, Version=, seems to be related to a versioning issue with the UiPath.Workflow assembly.

Here are some steps you can take to resolve this:

  1. Check UiPath Studio Version:
    Ensure that your UiPath Studio version matches the version installed on the machine where the process is running successfully. Mismatched versions can lead to compatibility issues.

  2. Clean Project Bin and Obj Folders:
    Before publishing, clean the project’s bin and obj folders. This ensures that the latest versions of the dependencies are included in the published package.

  3. Update Dependencies:
    In your project, open the Manage Packages window and update all UiPath dependencies to the latest compatible versions. Ensure that all activities and dependencies are consistent across your project.

  4. Delete Project.Json:
    Delete the project.json file from your project and republish. The project.json file contains information about dependencies and versions, and sometimes it can cause issues.

  5. Restart UiPath Studio:
    After making changes, restart UiPath Studio to ensure that all changes are applied.

  6. Review Dependencies in Orchestrator:
    Check the dependencies in Orchestrator. Sometimes, older versions might be cached. Ensure that the correct version of the package is available in Orchestrator.

  7. Check Target Framework:
    Ensure that your project is targeting the correct .NET Framework version. UiPath might have moved to a newer .NET version, and your project needs to align with it.

  8. Orchestrator Settings:
    Check the settings in Orchestrator regarding package versions and compatibility.

If the issue persists after trying these steps, you might want to contact UiPath Support for more targeted assistance. Ensure that your UiPath Studio, Robot, and Orchestrator components are all up to date and compatible. Additionally, make sure your project is using activities compatible with the UiPath version installed on the target machine.

Hi @copy_writes ,

How would I check the dependencies for the specific project on orchestrator and why would another project run successfully with the same dependencies? I have tried most of your other solutions as mentioned in the post. Thanks

Checking dependencies for a specific project on Orchestrator involves verifying the package versions associated with that particular process. Here’s how you can do it:

  1. Login to Orchestrator:
    Log in to UiPath Orchestrator using your credentials.

  2. Access Processes:
    Navigate to the Processes page. This is usually found in the left-hand menu under “Automations” or a similar section, depending on your Orchestrator version.

  3. Select Your Process:
    Find the process for which you want to check dependencies and click on it. This will open the details page for that process.

  4. View Package Versions:
    Look for a section that displays the package versions associated with the process. This might be labeled as “Packages,” “Dependencies,” or something similar. In this section, you should see the versions of the packages that the process is using.

    Ensure that the versions listed match the versions you are using in your UiPath Studio project.

    Orchestrator Package Versions

Why Another Project Runs Successfully:

  • It’s possible that the other project runs successfully because it is using compatible package versions or a different set of dependencies.
  • Each UiPath project can have its own set of dependencies and packages, and they might not conflict with each other.
  • Dependency issues often arise when there’s a mismatch between the package versions used in the project and the ones available on the machine where the process is executed.

To resolve this, it’s important to maintain consistency in package versions across all projects and ensure that the versions used in development match the versions available in Orchestrator and the runtime environment.

If you find discrepancies in the package versions, update your project in UiPath Studio, republish it, and then update the process in Orchestrator with the new package versions. This should help align the dependencies and resolve the versioning issue.

Hi @anan.deneke ,

I believe we do have some other similar related posts where the discussion was closed with a Conclusion. Could you check and let us know if it helps :

If it did not help, we would like to ask you about the Studio or Robot Versions used and the Dependency/Package versions used in the process.

Hi @copy_writes ,
I just checked and both studio and orchestrator have identical dependencies for this project.

To your point of why another project would run and this wouldn’t:
I always use the latest packages across all projects so the dependency in each project should be identical. I also mentioned I sent the same project to my coworker, and he uploaded it to orchestrator with the same dependencies and it ran fine.


Hi @supermanPunch
I am connected to Enterprise Orchestrator and my studio is the latest version. I downloaded my version of studio from the automation cloud with an enterprise license.

I am also not using any beta versions of packages.

I can’t find the option to downgrade studio or upgrade orchestrator but why would another project run successfully if it was a compatibility issue b/n orchestrator and studio?

My studio version was 2023.8.0 when creating this project but I have since upgraded to 23.10.0


To check ifdenpendencies are downlode properly navigate to below location and rwname the pckages folder and reopen the project so that the dependencies will be downloaded again



Hey @Anil_G,

That redownloaded the dependencies but it failed again too, I got the same error.