Could not load type 'System.Activities.TextExpressionBase`1' from assembly 'UiPath.Workflow, Version=, Culture=neutral, PublicKeyToken=null'

After new release 2023.8, newly deployed processes gets below error. Robot cannot start process.

Could not load type ‘System.Activities.TextExpressionBase`1’ from assembly ‘UiPath.Workflow, Version=, Culture=neutral, PublicKeyToken=null’.

Any idea how to fix this?

1 Like

Hi @snehal.dave

Any chance you could share a zip of a dummy project that reproduces this issue for you?

The issue/solution I found is, if package build on Community version and deployed onto Enterprise Orchestrator, the code doesn’t work. If package build on Enterprise Orchestrator connected Studio and then deployed onto Enterprise orchestrator, it works.

So Community orchestrator and Enterprise orchestrator has major different versions. It used to work viceversa but this has stopped working and throws error.

Community Studio - 2023.8.0

Enterprise Studio - 2023.4.1

If your development studio version didn’t match with the production studio version then you may face this issue while execution of robot on production.

Solution : Simply update the studio and make version uniform in development and production.

1 Like

My Studio version is higher than Orchestrator version. My studio got updated automatically. Don’t know how to update Cloud orchestrator though.

Apart from Studio, what is the version of the System activity package in the scenario where you move the Community process to the Enterprise Orchestrator?

And a side question, because it is always best to develop within one environment (if an enterprise, then everything enterprise, if community, then everything community). What is the reason you are splitting the development this way?

Hello. I am having the same error. I was publishing from a community version into an enterprise version and when i ran it at the client, I would get the error message. Now I am trying to publish from my enterprise version, and it will not publish because of that error.

I am also getting the same error not able to run bot remotely My UiPath Studio Version is Studio 2023.8.0 Community Edition, UiPath Assistant Version is UiPath Assistant 2023.8.0-preview, Orchestrator is also a community vesrion I am getting this error after the new Update any solution for this?

If you are using any package which is higher than any available in Enterprise version then it won’t work. Don’t use beta versions in Enterprise versions. If you lower the versions available to match with Enterprise and publish, it will work.

Uninstall community version studio and install Enterprise dev studio and link with that Enterprise cloud orchestrator to resolve the issue. Enterprise studio is 2023.4.4.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.