Connecting Studio to Cloud Orchestrator Tenant NuGet feed

I have set up a cloud UiPath version and I’m testing the Libraries feature.
I have configured the Library feed to be Tenant specific and I’m able to publish my libraries (I see them in the Orchestrator under Libarires)

However in Studio Manage packages, I cannot find my libraries. Do I need to configure additional Tenant specific NuGet source to being able to use them?

Thank you!

image

1 Like

Hi.

You need to go to Manage Packages > Settings, and check that you have the Orchestrator Host set up and checked. If it’s not there, then when you add it, it should be the path to the cloud orchestrator then add “nuget/activities” on the end. - I could be wrong on that last part though.

1 Like

@ClaytonM Thanks, unfortunately I still cannot see the packages.

Here are the combinations that I tried. 1-4 does not throw any error, but doesn’t show the packages either:
image

Did you restart Studio after adding them, and selected the sources on the left hand side where the packages show up and nothing was there?

If that doesn’t help, look over this on library feeds to see if it might help identify a solution: https://docs.uipath.com/orchestrator/docs/about-libraries

If I think of anything else, I’ll let you know.

@ClaytonM
I restarted yesterday UiPath Studio/Assistant few times, but at that time it didn’t solve the issue.
Now over night the tenant specific feed has appeared automatically and everything works.

Many thanks for your help!

1 Like

This is a pain! So far I was able to access my Tenant library feed. It started this morning and I’m getting this error. This is happening on both my Cloud Orchestrator instances. Can someone clarify, why this is so unstable? This note appears each time I navigate between package sources. It stops if I uncheck the Orchestrator Tenant source in the Package manager.

I simply do not understand why the URL needs to contain a cryptic GUID that no one can remember for the love of life! Where does the GUID originate? And as an admin of my Orchestrator, where can I find it?

I plug the URL into my browser and I get this message:

{“code”:“NotAuthorized”,“message”:“User is not authorized”,“feed”:{“id”:“b10da17f-34a9-44a1-9738-f021e698daeb”,“name”:“Libraries”,“tenant”:"<>"}}

Can you kindly let me know how to fix this issue? My libraries on the Tenant are not visible.

thanks

I deactivated the feed. Then added it back in and restarted Studio. And now it works! I don’t understand why!

Here are the screen grabs of my set up:

Without that GUID in the URL the feed does not work. I had originally added the Feed underlined in Red and it was in the standard pattern. But them my Studio seems to have this “Orchestrator Tenant” added to it. I did not add this for sure because my office laptop that has studio installed has a similar “Orchestrator Tenant” feed on it that contains a GUID. I don’t know what that GUID in the URL means.

Can someone please shed light on this because I can’t seem to get this URL pattern working for my tenant feed:

https://platform.uipath.com/[Org]/[ServiceName]/nuget/activities/[tenantlogicalID]

Thanks much!