CommandLine Issue: 'Cannot Unload Project' in Studio 23.4

Dear Community,

I am running into some issues with using the CommandLine in Studio version 23.4

I am trying to run an analyzes on a project via the CommandLine. I created a new Process() with the following StartInfo:


@"The project 'C:\Users\xxxx\WorkflowAnalyserTestProject\project.json' could not be opened: Unable to properly unload Workflow Project.

Al my UiPath packages are on the latest patch of 23.4.

I have tested the same code with Studio 23.10 on a different machine and it works fine, no issue with unloading the project. However, I need to make it work for 23.4 as well. Does anybody know what the big differences are of the commandLine of 23.4 and 23.10? And why 23.4 might be causing issues?

P.S. I also tried running different commands like managing packes. But all commands fail because the project cannot be unloaded by the CommandLine

Hope sombody can help me!
Kind regards,

Hi @Mees_Mouwen

Check out the thread

This issue has been fixed in 2023.10 update.


Hi @Parvathy,

Yes I saw this post you reference to. However, 23.10 is causing some issues for other processes we are running. Meaning we are still using 23.4 on many machines. This is why I am looking for a solution for Studio version 23.4. I looked through the release notes of 23.10 but could not find a reference to how this was solved in 23.10.
Do you think there is a workaround in 23.4 for this issue?
Kind regards

Issue has been solved.
It was being caused by CodedWorkflows function being set to TRUE in version 23.4
Without this setting, the CommandLine could unload the file.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.