Column not found

Screenshot 2023-07-27 212028
column not found

I’ve ticked “add headers” when i read range

Hi @helpplease

You are using Write Cell, so you need to define it which column you need to write means A1, B1 like that instead of writing the column

Hope this may help you



Can you check the following post , similar to your problem.

1 Like

^ this is what I am trying to do

Can you share the place where you have added column headers or changed it to date

Is 1/9/2022 the header, that’s what you want the column named? I’m pretty sure you can’t have / in column names. I recommend creating better headers in your source document.


I just tried Headers with / symbol and it worked actually, Data can be retrieved if column Headers contains / symbol
Also, I agree with @postwick such names are not recommended for Column headers

1 Like

Ok I wasn’t sure. Thanks for testing.

What if you try to output dt_test.Rows(0)(“01/02//2023”).ToString

I get the output

1 Like

Hi @helpplease ,

I believe you’re using the Write Cell activity, for that the error states that the column not found because the Write Cell would need the column names like A1, B1, C1, …

I believe you are missing a Step on converting the Datatable column name / the Column Name value that you have to a Excel Letter Column Name. Do check the post below, which also discuss the same topic :

Hi @helpplease

Please find the below xaml for your reference (167.3 KB)

I hope it helps!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.