Client Security Hash - Extract Client Information - Bug? - Studio Processing Multiple Times

Hello Beautiful People,

Encountering an issue that is preventing me from completing the Client Security Hash. Wondering if any of you have come across this before.

While processing my work items, I’m encountering a bug where I’ll process the first transaction twice. When running through the second time it for some reason skips my ExtractClientInformation. Grabs the info from the first transaction and sets that for the extraction by the hash. Funny thing is that it will navigate to the work item page just fine. Just skips the extract??? It will run the rest of the bot just fine. It only happens on the second iteration. Also if I set up break points and run through it, it will work??? I’m so confused. Any help on this would be great.

Mr Monkey,

(Or is it “Bot, Monkey”, in which case it is Mr. Bot),

I completed Client Security Hash last week. I am 99% certain your issue is going to turn out to be timing, or a coding issue in your Bot.

I suggest timing, because typically, when I have had issues that worked single step from the debugger, but not when run, it is because something is happening slower than my code expects.

The only way anyof us could help would be to look through your code and debug the issue.

What I would suggest is the brutal debugging technique of putting a write line between each activity to check that you have the right values coming out. Put a write line inside the extract info, and make sure it is really getting there, and to each of the steps. Dump out the variable values and make sure they are what you expect.

@mjdeale I have and they are. As you can see from the work items url everything is getting pulled right, right up to the point of the extraction. It initiates the navigate to WI details but then the extraction gets skipped. And it only happens the second time. Every other time and the first time they get pulled right. Going to try a couple of things and I’ll let you know

I think I would put a write line at the bottom of Extract Client Info and dum the three output variables.

I think I would also put a write line as the first activity and print “Entering Extract”.

Make 100% sure I knew I was getting into the workflow, and 100% certain what the output values are in the workflow itself. It must be something inside that workflow!

This is so funny it makes me want to cry. I’ll share it with you. It’ll work if I stick a msg box in there and give it time to think on the page. Now try and remove the Message Box in the System_ExtractClientInformation and see what happens. There is nothing in the process xaml that in between the Extract and the hash. If you can figure this one out, I’ll owe ya one! Sending ya the workflow in a pm. Keep comments to this page please for documentation

Had to reboot my Vm (I run UiPAth in a Windows 10 VM on my Macbook Pro). UiPath was crashing it. Let me download and check it out.

– M

1 Like

I have convinced myself that I was right in my first guess. Your robot is fast enough that it is grabbing the data out of the web page BEFORE the navigate has finished loading the html page it was navigating too.

I proved that to myself by using the write line activity (Not the message box, because that changes timing by stopping the process).

I wrote out the WIID when you navigated to the Work Item, then inside extract, I wrote out the variables you were extracting.

What I observed was that you would navigate to the correct work item, and then pull data from the prior work item. The only way that happens is if you get to your extraction code and execute it before the Explorer web browser has had a chance to actually execute the navigate command. Remember all of this stuff is happening asynchronously. Your robot and Explorer are running at the same time in parallel.

So, the problem was solved by your message box, which stopped execution of the robot between navigate and extract, and gave the browser enough time to execute the navigate before you could click ok.

The solution is actually pretty easy. In your extract of the text (Get activity targeted at the paragraph with the Client Info) , I changed the WaitForReady from blank to Complete, making it wait until the page is fully loaded before trying to extract the information.


In transit now. Sounds like that’s the fix. I’ll let you know as soon as I hit the homestaed

That did it! Thank you so much!

General addition… I think something changed in UiPath to make this an issue. I use Navigate activity in Level 3, Exercise 3 - Generate Yearly Report, and had the same problem. My get text activity after the navigate activity was extracting data from the prior web pagepage. I had to add the WaitForReady = Complete to get the correct data out of the web page.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.