ClickBeforeTyping doesn't work as expected

I have a field which doesn’t seem to work unless I click into it before the value is typed in. I selected the ClickBeforeTyping option in TypeInto, but it doesn’t seem to do anything.

The workaround I have implemented is adding a separate “click” activity before the TypeInto step and using the same selector as in the TypeInto activity. This seems to do the trick, but should the ClickBeforeTyping option do the same thing? Does this seem like a bug?


Hi buddy
Welcome to uipath community

Yes you are right clickbeforetype should work as you say but make sure that these properties are also enabled
-Simulate type

That’s should work for sure
Kindly try this and let know for any queries or clarification
Cheers @vict46

1 Like

Thanks for the suggestion @Palaniyappan, I tried the properties you suggested but Simulate type does not seem to be an option. I get the following error:
Message: Cannot use UI_CONTROL_API on this UI node. Please use UI_HARDWARE_EVENTS method.

What is the UI_Hardware_events method? I am performing these activities in Oracle EBS Java application. I tried SendWindowMessages instead and although there is no error, the outcome is the same as the default method.