Click First Column in Excel Fails in Unattended

Good day friends - I hope we are all well. So I have a weird issue.

I have an automation that runs perfectly well on Remote Desktop Connection in attended mode -as I watch the screen but he moment I schedule in Orchestrator, it runs well but it throws an error in a particular click activity.

However this click activity works just fine when I run the workflow with the Ui Assisant.
Its running on a production unattended license but I cant move on to other tasks as the bot is actually being used by the Ops team.-But I have to run it from the Prod server.

Any help would be greatly appreciated.


Can you please say what is the selector youa re using?

And did you check the screen is it on the right screen?


Hi @odure

Just check if you gave the correct Selector for Excel File, specifically FileName should be replaced with wildcards.
Rest it would work.
Don’t use Simulate click over there in Excel UI Automation,
try using Send Windows Message first, and if it doesn’t then bring the Excel to foreground and use Hardware Events.

Happy Automation!

You could try click text activity as well, maybe that helps in your case

Hi @adiijaiin I have tried this but still get the same error - ive decided to make this bot attended since in attended mode there is no error and the workflow executes seamlessly.

Many thanks

Yes - I tried this too but it still through the error - opposite to the item that needs to be clicked is a similar TEXT that I think is throwing the bot off.