Check App State Not Moving to 'Does not appear'

Sorry - i’m not super experienced. Are one of these settings what I should be looking at for visibility?

No, we would inspect the element within uiExplorer


I don’t think that’s something I have unfortunately.

Ok you are the case which is really working in StudioX. In such case you can use a UiAutomation Activity (e.g. click) for the analysis and comment it out when not needed

Also have a look here:


I figured this out! Is there a way to change that setting to false? Is that what I should do?

Yes. Set the “Visibility check” to “fully visible”

Before mixing up:
Statement was about: RelativeVisibility

In a next round

  • now crosscheck if box was ever displayed once before
    AND
  • is now hidden

We need to confirm that now relativeVisibility = false

Ensure that all Selectors / UiExplorer Panels are refreshed and at the current state, as this check is crucially

Hi Guys - I set the visibility check to ‘fully visible’ and now i seem to have the opposite problem where it can’t detect the object and goes straight into the ‘target does not appear’ menu.

better not mixup different options / suggestions.

So just model one option (as you have started with) complete as suggested and with assistance.

Once it will not help, then feel free and try other suggestion. But also in a clear way and complete.

One time I highlighted the check app state object and it gave me a uiexplorer recommendation, but that no longer comes up and is not a part of the StudioX package it would appear. Is there a way to download this separately?

Otherwise - it seems like if i set the visibility check to ‘Interactive’ it looks for it every time and is able to interact with it. If I set it to ‘fully visible’ it just can’t see it at all and jumps to the ‘target does not appear’ option. If there isn’t a way to get the UiExplorer thing, is there a setting in here I can mess with?

image

10 seconds may be too short a timeout

But i have it as ‘element to appear’ with a 10 second timeout. If it doesn’t appear, shouldn’t it just move into the ‘target does not appear’ window? Right now it seems to just not move into ‘target does not appear’ under any circumstance.

If the element is visible within 10 seconds and it goes to does not appear, then your selector isn’t right.

Show us your selector(s) including the window selector portion. Also, which selectors do you have checked ie fuzzy, strict, image?

Sorry - to clarify, the element does not become visible, so i WANT it go to go ‘does not appear’. I am trying to say - if this popup appears, click continue and go back to the beginning of the loop (this part seems to work). If it does NOT appear - go to the rest of the flow (right side of automation). Below is the flow I built as well as a screenshot of the popup window that either appears or does not. Does that make sense?

Yes it makes sense but you had said it’s not going to the target appears branch. Now you’re saying it does. What’s the problem you’re having?

If I have the ‘Fully Visible’ visibility option selected, it automatically goes to the ‘target does not appear’ side. It seems that it can’t detect the pop up window that i screenshotted above. If I have the ‘Interactive (for fuzzy selector)’ option selected, it can detect the popup window and click through it, but if the window never appears it just keeps trying to look for the window, times out, and posts the error message I posted above on Sept. 19.

It seems that whatever I choose it will only go down one path or the other.

I was able to figure out how to get back to uiexplorer menu and relativevisibility is ‘true’ when i select this box.

Hi All - any other ideas here that could help? Thank you!

Fixed by selecting strict selector only and removing other selected items.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.