Can't navigate to a new URL in a new tab in Chrome

Hi,
I recently got UiPath and I have encountered this problem fairly early on.

I open a site in Chrome using “Open Browser”, login to that site, and then open another tab using “ctrl t”, navigate to a URL, and login to that site as well.

However, after the new tab is opened, all the actions I want done on the new tab are done on the first tab. From what I can tell, I can’t seem to attach browser to the new tab, and I can’t seem to type into the search bar because the selectors won’t validate.

I have tried these solutions:

Any help would be appreciated.

Thanks!

Sean

1 Like

Hi @sellner! First of all , welcome to our community!

Did you already install Chrome extension? If Yes , can you post a screenshot of your xaml file?

~Diego Turati

1 Like

Hi Diego,
Thank you for the welcome!
Sorry, I am super new at this. Is this what you wanted?

1 Like

Hey, if you’re new or not it doesn’t matter and it’s not a problem my friend!

Everybody here is like a big family and we will try to do our best to help you ok?

Great, your screenshot is good.

First of all , check if you have Chrome extension installed as follow below:

If it’s not, you need to install it:

In your Studio, in the left side menu, you have the option : Tools. Click on it and you will see the chrome extension option to be installed in the right side as you can see below:

Let me know if you was able to identify it.

~Diego Turati

Thank you! Yes I do have the extension installed! It is greyed out when I open a new tab though.

1 Like

Hi @sellner,

Buddy i think the issue is all because the page is not getting recognized thus selectors are getting recognised. If there is no chrome extension available, you would have not performed activities in first page of the browser in first tab (as you mention)

So kindly add attach browser activity before you navigate to different URL in a browser. Or
kindly add attach window activity before navigating to each page in same URL.

Lets try this and sort this out together, This can be easily resolved

Cheers…!

1 Like

Great Sean!

Try to add attach browser activity before you navigate to different URL in a browser. Or add attach window activity before navigating to each page in same URL.

~Diego Turati

1 Like

Thank you both for the replies!
I tried the attach browser and window as shown here:

And here is what I see when I open a new tab and how the UiPath extension is greyed out on the top right:

But on any other page other than the new tab page it isn’t and I can choose more specific selectors that validate:

The only selector that will validate on a new tab is app chrome.exe, but then it will do the actions I want done in the first tab instead of the new tab. And even though I have the attach browser and window, I set up a try catch to see what the problem was and I get this:
image

I feel like I am probably just missing something. Once again thank you for the help!

-Sean

edit: I was using an existing browser variable. But even when I try to indicate the new tab on screen, it will run without error but still do everything in the first tab and nothing in the new tab

Sean, is there’s some confidential data? Case not, you can send me the xaml file, then i can check it better here.

~Diego Turati

Sean, here is a troubleshooting article for Chrome extension:

studio.uipath.com

Chrome Extension

This topic presents the most frequent reasons for which the UiPath Chrome extension might not work properly, and how to solve these issues. Check if the UiPath extension is installed and enabled: 1. In Google Chrome, navigate to…

I would suggest to uninstall the extension - restart Studio - reinstall - restart again. And please check not to have two extensions installed.

~Diego Turati

@sellner
NO NO NO…buddy, i will explain,you are almost done, but…its not that ui extension is getting grayed when new tab is opened i will give a example,

  1. without entering url now see here as you say uipath extension is in grey mode

  2. When i enter any url or trying to open a webpage say simply google see now,


    uipath is getting enabled…

so its not the extension issue for your process.

now the problem attach window that you have given has no url at all

and very next activty yo are using navigate activity to enter the url. so the page changes and window changes, where unless you mention the type into must be performed in this window or page, it wont find

the solution is

  1. create a another attach window activity with the same selector of the very first tab attach window activity.
  2. Now add this attach window activity with same full selector inside (ABOVE HIGHLIGHTED) that attach window next to the navigate url
  3. mention all the followed activities inside this attach window activities.

This will work, lets try.No worries

Cheers…!

1 Like

Hi all,
I reinstalled the UiPath extension and it didn’t work. And the file does contain confidential information, so I tried to recreate the issue by remaking a similar process to share with you and doing the same thing I’ve done in the original program. And this time IT WORKED!
But I couldn’t get the the original process to work, even doing all the things you recommended. So I just created a new process and just redid everything I did in the original and it worked.

So unfortunately, I don’t know how it was fixed, maybe it was just a bug?

1 Like

Maybe jeje! But since you reinstalled you can close this subject as solved by this just to close the topic thanks @sellner Sean

~Diego Turati

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.