Can't create a queue definition through the Orchestrator REST Api

orchestrator
queue
api

#1

So, I was able to authenticate perfectly to Orchestrator, but now I am trying to submit this request to create a Queue Definition and getting that is null. What can be happening? Thanks

POST: https://website/odata/QueueDefinitions

Headers: Content-Type: application/json, Authorization: Bearer + 'token'

Body: {
    "Name": "Test",
    "Description": "something",
    "MaxNumberOfRetries": 5,
    "AcceptAutomaticallyRetry": true,
    "ArchiveItems": true
}

Response: {
    "message" : "queueDef is null!",
    "errorCode" : 0
 }

#2

I have the same issue


#3

Hi Vadzim,

I have just tried on https://platform.uipath.com/odata/QueueDefinitions
{
“Name”: “string”,
“Description”: “string”,
“MaxNumberOfRetries”: 2,
“AcceptAutomaticallyRetry”: true,
“EnforceUniqueReference”: true,
“CreationTime”: “2017-11-27T10:27:12.937Z”,
“Id”: 0
}

and it created the Queue successfully.
Can you show your request?
If it helps, please take a look at the Orchestrator 2017.1 API Guide


Uipath.webapi
#4

Hi, the answer is update to the latest version. It was definitely a bug (or documentation issue). When I updated, and removed the flag ArchiveItems (not used anymore) it worked