Cannot write to google sheets using Apikey authentication type

Hello!

I am trying to use write range to write to google sheets but encountered the following error:

Write Range: Request is missing required authentication credential. Expected OAuth 2 access token, login cookie or other valid authentication credential. See Integrating Google Sign-In into your web app. [401]

I am using ApiKey in GSuite Application Scope. According to the gsuite documentation here,https://docs.uipath.com/activities/docs/gsuite-application-scope , I should be able to use write range (a Google sheet activitie) using ApiKey. But why does the error message suggest that I need OAuth authentication?

image

Note: there was no issue when I use the read range from google sheet within the same workflow

Any help is appreciated

Hello @Santiago_sg I would like to help you, Can you share a Screenshot of the Gsuite Scope properties that you are using?

Hi @Manuel_Dominguez ! here is the screenshot of the Gsuite Scope properties, thank you!

Ok, First all Can you Enable all the Checkbox from the Image that you shared, and try again, and type “notasecret” in the property Password
image

Let me know, I have another Options

I tried, but unfortunately I face the same error. What are the other options? Thanks!

Can you validate if the Google Account has this option Eneable

Also Can you validate if this are Enable

Go to https://console.cloud.google.com and select Library

Then Open these Options and validate if they are enable

Let me know if that works

Thanks for the detailed instructions.

I enabled both the Google sheets and Google Drive API and also enabled the “Less access apps access” (Acceso de apps menos seguras).

However, the same error message persists during write range. I am confuded by the fact that the within the same Gsuite application scope, the read range from google sheets works without an error.