Cannot Start a job via an API call in Postman "startJobParameters must not be null"



"startJobParameters must not be null"というエラーが出され、


Check these articles:






The easiest way to check by yourself if that process it is allowing the input arguments and how is to monitor the Orchestrator UI Rest API call in the back-end with Inspect tool in the browser (I prefer Google Chrome).

So in my example, I found that the InputArguments should look like


Let us know if this helped.

Thank you for your reply.

I tried that method right away!!
But I didn’t get the result like yours.

Can you tell me what is wrong?

Start the Inspect tool before accessing the Processes tab. Perform the needed actions and then you will be able to see the call and the payload.

Let us know if this is clear.

Thank you and sorry for the late reply.
I tried, but I couldn’t…

I started the process with DevTools open and got the results as shown in the image.

By the way, [Jobs ~…] is displayed like this.

thank you.

I am contacting you because I was able to resolve this issue.
It looks like the robot argument settings were wrong, not the postman settings.
Thank you for your help.

I am glad that you were able to solve the issue. Mark as a solution the correct post in this thread that helped to solve your issue. In this way, you will help others to find easier what they are looking for.

Thanks for understanding.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.