Cannot remove unsued robot from Orchestrator

Hi all,

I’m currently having problems with removing an unused robot from Orchestrator 2018.1.1. I keep getting the message “This robot has pending or running jobs and cannot be deleted.”

I’m pretty sure I have removed all references to that robot from Scheduled, Packages, Queses and Environments. As far as I can see there should be no dependencies - certainly no running or pending jobs (the robot has been dormand for 21 days).

I tried to rename the robot and then delete it. No effect.
Then I restarted the IIS, thinking this would clear the cache and re-load everything from fresh - but to no effect.
Ultimately, I have powered down the whole installation (IIS + DB). When it came back up nothing had changed.

What else can I do?

I am very much tempted to go into the database and mark the particular robot as Deleted = True. But I think it is probably more complicated than that, and its definitely NOT the right way.

Best regards

Hi @KlausA: Can you please double check the Jobs page, are there any processes still in pending state? Also maybe look at the System tray if the robot is connected and try to disconnect the robot from there.

Hi @KlausA

  1. backing up what @PD2 said.
  2. what is the Robot’s status? Only if the Robot is Busy it cannot be deleted.

Hi you two,

first off - as stated initially, the robot is totally off line: no jobs, no resources, no queues thus no dependencies what I can see/look up in ORCH. It was taken down after a couple of test runs. Since that was some time ago I wanted to re-used the robot license.

PD2 - you gave me an idea which eventually solved my problem. I re-enabled the robot and suddenly its status changed to “running with problems”. It terminated with an error saying that the process did not finish. It was the process mentioned above. Naturally, it no longer existed since it was cancelled and removed from ORCH weeks ago. And to pre-empt your question: yes, I did stop the process and removed the schedule before I took down the robot. Everything looked fine.

As it turned out, there was a process currently “under execution” which prevented me from deleting the robot. After re-enabbling the robot and clearing the schedule, ORCH was satisfied and let me delete the robot.

It makes sense not to delete the robot before any processes are done.

However, in this particular case, I removed any references to the process. Furthermore a couple of weeks went by (with at least two restarts of the server) before I wanted to delete the robot - and I could not see anywhere in ORCH or in the DB that there was “unfinished” business. That was what threw me off…

I hope others can benefit from this work around if the encounter an undeletable robot :slight_smile:

Best regards


I am facing similar kind of problem. I am not able to delete a JOB which is associated with one of the robot.

Why i am facing this issue and how can i resolve this.

Hi @ChitraPal

Jobs cannot be deleted from Orchestrator.
The original post was about not being able to delete a robot.


Hi I’ve the same problem. I’ve a unresponsive robot in the orchestrator, but the machine doesn’t exists anymore.

But when I try to delete from orchestrator the robot/machine, the remove logo is grey and I cannot delete the robot.

I cannot reconnect the machine because the machine doesn’t exist, and there are no schedules or jobs pending


1 Like

Hi I have a similar problem, I was able to delete the robot as that machine didn’t exist and when I try to update I am not able to update the machine name. So I ended up deleting, now I am unable to add one with new machine name. Though I don’t have any robot I am seeing 2 robots under my account. I am using community edition.