Cannot communicate with browser, please check UiPath Extension


We are using UiPath 2017.1.6522 and added the UiPath extension in chrome and it works all fine in the local machine. When the code is deployed in a VM, we are getting the below error,


We have added the UiPath extension in the VM machine and checked all the access.

The chrome version the VM is Version 71.0.3578.98 (Official Build) (64-bit)
Tried all the solutions mentioned in the forum with no luck.
Can anyone help in resolving this issue?

1 Like


have you tried reinstalling the extension and also check the plugins permissions and enable scripting, active x etc?

1 Like

The extension shows below error message,

I tried re-installing the extension, but no luck.
where to check Active X, enable scripting?

1 Like

Can you give me more details on what all you have tried doing and what is the error in detail please… thanks :slight_smile:

1 Like
  • Downgraded Chrome to Google_Chrome_(64bit)_v71.0.3578.98 as mentioned in one of the posts in the forum.
  • Reinstalled uipath extension for chrome
  • Restarted the VM
  • The ChromeNativeMessaging.exe does not seem to run when the chrome is open

The error is the same for all, “Cannot communicate with the brwoser, please check the UiPath extension”

1 Like

Hi @kavyashreeh22

Have you tried to troubleshoot with our documentation?