Cannot choose tab in Excel 2013 but I can do so in Excel 365

Hi All,

I came across a really weird situation. I created a UiPath package dealing with Excel manipulation running very well on Excel 365. However, the same package cannot be run on Excel 2013. After digging in, I realized that issues boiled down to the fact that the selector can choose (click event) a specific tab in Excel 365 but it failed in Excel 2013. I searched it on Google but seems very few posts available on this topic. your help is much appreciated



I had the same problem in one of my excel automations. In the latest version or excel i was able to click on almost anything on the excel UI including sheet tabs and other stuff. However, when it was put to run on environment where you have 2013 version, it was unable to identify those items to click. Just like you mentioned here.

The option to take in such scenarios is to use the hot keys to navigate around excel options. That worked perfectly on both versions of excel…


Hi Lahiru, many thanks.

I also found out it was caused by the latest upgrade.

It worked all good with older version

“dependencies”: {
“UiPath.UIAutomation.Activities”: “[18.4.3]”,
“UiPath.System.Activities”: “[18.4.2]”,
“UiPath.Excel.Activities”: “[2.5.0]”,
“UiPath.Mail.Activities”: “[1.3.0]”
“schemaVersion”: “3.2”,
“studioVersion”: “”,
“projectVersion”: “”,

but it failed with below:

“dependencies”: {
“UiPath.Database.Activities”: “1.2.6863.32528”,
“UiPath.Excel.Activities”: “2.5.0”,
“UiPath.Mail.Activities”: “1.6.0”,
“UiPath.System.Activities”: “19.8.0”,
“UiPath.UIAutomation.Activities”: “19.8.0-ce”
“webServices”: ,
“schemaVersion”: “4.0”,
“studioVersion”: “”,
“projectVersion”: “1.0.0”,

1 Like