Can not use Http Request

I have install the latest version 2018.1 of UiPath Studio, but I can not find Http Request Tool in it. Also I can not find UiPath.Web.Activities.Design.HttpClientWithBodyFactory this package installed.

My environment is Win 10.

Could anyone provide suggestion?
Many thanks.

Orvin

Hi @ochen027,
Please take a look :

Regards
Balamurugan

Have you tried installing the packages from Manage Package option?

Thanks @balupad14 , but it seems that this video deprecated.
and I know that, but there is no web package in my Manage Package.
So I can not use this application integration to call web service.

Thanks @pawanbag
BUT in my UiPath Studio, I can not find this package, either in Installed nor in Available.
Any more suggestion?

@ochen027

It isn’t obvious at first but you need to go to the second page of the Packages. It’s a little arrow bottom right.

Regards
Troy

Thanks @tmays, I found it, but when I have installed it, the Activities do not show it. Please check attachment.

Oh wow. You’re not seeing any activities. Have you ever seen any others besides System? Have you restarted Studio?

This seems kinda drastic but take a look at this post and see if anything in there helps.

Thanks @tmays
I have reinstall UiPath and it seems Activities shows correct, but in manage package, it shows I have installed Web package, but activities still do not show http request, only have Orachestrator HTTP Request, this request can not call webservice by OAuth.

Type HTTP in Search Activities. HTTP Request is under App Integration.

image

Thanks your help, @tmays
I know that app integration, but when I have install web package, the tree still do not have this element.
Please check screenshot from my environment.

Dang dude. I don’t know. Have you tried installing on a different machine? yeah not much help, I know. Sorry.

Thank you all the same, it seems it is ok on my colleague’s PC, but the version is 2017, not the latest version.

Hi,

I am not able to find ‘UiPath.Web.Activities’ package, i am using 2019.10.3 version. Is the name of this package changed or if there is something else you can help on this topic.
Thanks in advance.

Did anyone got any solution to this as I am also not able to see the http request activity even after web pakage instaaltion