BusinessRuleException in library error

Hi,

I have a activity in a library that throws a UiPath.Core.BusinessRuleException exception, when I drag this activity in a sequence in my other project it says “Type UiPath.Core.BusinessRuleExceptionis not defined” and thus won’t run.

Here’s a screenshot:

I’ve tried adding/removing dependencies, ensured the UiPath.Core is in the imports… thoughts?

Cheers

Hi @mschuurman
Is there a particular reason why you wouldn’t throw it via the available Throw activity?

The “Open” activity in the library uses the available Throw activity. But it does more than just that, the throw is only triggered when something goes wrong.

Could you share some of your custom activity code? I believe the culprit to be somewhere in there (but I’m not sure).

Right, I’ve been playing a bit more with it and it seems forcing the sequence to be saved (e.g. make a change, undo and save) resolves the problem. I’m guessing it has to do with the internal dependencies (on .NET) somehow getting corrupted.

Below’s a diff of the dependencies in the XAML file, so the sequence itself did not change I merely forced it to re-save.

Problem solved

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.