[BUG] Get Queue Items not checking for queue in current running folder

There is a bug with the Get Queue Items where if ‘Folder Path’ isn’t declared it’s not checking for queue in current running folder, it’s going for root folder in the modern folder tree


As you can see here i have a root folder name ‘Root’ this is where we have all our assets
in the sub folders is where we have all our queues so we don’t mix production and development data on the queue and stats side.

Get Asset will check for asset in the running folder, so if I run an automation from the development folder it will look for the asset in that folder, this was expected, so we changed the folder to check in “/” and bingo, it works as all our assets is in the ‘Root’ folder

Now i wanted to use the ‘Get Queue Items’ and expected the same behaviour but boy i was wrong
It will default to the root folder and if you try to define that it should look in the ambient folder by defining “.” or “./” in folder path it just throws the same error. Then for fun i tried to define folder path like this “/Development” forcing it to root and then ambient and it works. Then to verify that it is looking in the root folder as default i defined folder path like this “./Development” forcing it to start in ambient folder, and then go into development folder and this works, concluding that even if it is run from a subfolder like in this case, the activity ignores the real ambient folder.

I know of multiple ways to temp-fix this like arguments, config files and such, so i don’t have to release multiple version but that is not the point of this topic, the point is it should be looking in the ambient folder when not defined :slight_smile:

@Rasmus_J when no folder is inputted in Folder Path of the Orchestrator activities the folder that is selected in Studio will be considered as the current folder.

1 Like

seem like i need to update my certification :slight_smile: thx for the info

okay but why the different behaviour when looking at the “Get Asset” and the “Get Queue Items” activity. The Get Asset was looking in the folder is was run from for assets untill we defined it to look in root of the tree, and that was while that setting was set to root. So that one doesn’t behave as you describe.

To be honest i would prefer that it would look for the resource in the folder is is run from instead of us having to define it, because defining it will lock the package down to only be able to run in a specific folder, and it’s bad when sharing package feed, where as if lets say we develop an automation and we finally gets to a point where it’s ready for production. We would have to publish it twice, once for the Development, and without changing anything except the setting you point out, we will publish it again for production. That means that using the same package feed we now have the latest version availble in both dev and prod but the latest will only work on one of them.

Hi @Rasmus_J

I’ve just tested it on the latest Community Edition (Studio 21.6, System package 21.6.1) with the Cloud Orchestrator and it looks to be working as it should now.

I recreated your folder structure and then run a sample process that uses the two activities:

  • in the context of each specific folder
  • with nothing in the “Folder path” property
  • with "/" in the “Folder path” property

I had the identically named asset in all 3 folders (root, dev, prod), as well as an identically named queue with different amount of queue items that my process would count.

For the jobs that run with the process without any paths to Orchestrator, it always took the asset and queue of the specific folder.

For the jobs that run with the “/” path from inside the Dev/Prod folders, it took the asset and queue from the root folder.

To summarize, I think it is currently behaving as it should :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.