Browse For File doesn't work

UiPath.System.Activities 23.4.4

Add the activity, run the process, nothing happens. It just goes right past the Browse For File activity without ever prompting me for anything.

I figured out it works if I don’t try to use the Custom filter. Which isn’t really helpful because I need to define a filter. Also, the window that appears still doesn’t appear over top of the Studio window. Why hasn’t this been fixed yet?!

Well now I figured out that it wants "JSON | *.json" as the filter value. But when I enter that, the filter doesn’t actually work, I can’t see the file in the Select window. If I change it to just “*.json” it still doesn’t work and then when the execution ends it automatically changes it to "JSON | *.json"

Doesn’t this stuff get tested before release? /frustrated

I upgraded back to 23.3.4 and now it pops up on top of the Studio window but the filter STILL doesn’t work.

If I type *.json and then click Open…

Hi @postwick ,

The Configuration filter for Json seems to be working for me :

If you are running in debug mode, it could be that your UiPath Studio window is covering the Browse For File window. NOTE that the window will not show as an item in your taskbar, clicking on the UiPath execute item in the taskbar will not bring it up either. Try using Windows task switcher (Alt-Tab) and see if it contains the Browse For File window.


The browse window does exist, but it doesn’t come to the top of other windows. That’s the problem, and it has been a known problem for a long time.

1 Like

Thanks for reiterating your frustration with this issue. I double-checked and it continues to reproduce for me on Studio 23.10 with System 23.10.0-preview.

We will have a look!

1 Like

Hi Maciej,

I’m also experiencing the same issue when I use the Browse for file activity in my workflow. Please help.